Page 1 of 1

New version update 1.5 causes game to crash

Posted: Mon Dec 20, 2010 2:53 am
by tswita662
Pip,

When I tried to run the game after the version update from 1.4>1.5, the second screen hangs up and gives me the following error message in the BA:BA.exe-Fatal Application Exit dialog box. ***Unhandled Exception! ExpCode:0x80000003 ExpFlags:0
ExpAddress:0x77478B2E Please Report. I also get "Missing download List UI Object". The error only occurred after loading the new update. What gives? The game ran great until it was updated.

Thanks for your help.

Posted: Mon Dec 20, 2010 4:24 am
by junk2drive
You can wait until tomorrow for an official answer but I would uninstall and reinstall and update again.

What operating system do you have?

Sounds like your firewall or AV blocked your download or you just got a corrupt download.

Posted: Mon Dec 20, 2010 10:56 am
by IainMcNeil
Can you try using the external update installer and see if that helps. Before you do, delete the file in Battlefield Academy\core\v.txt

This contains the version number and if it cant find it it will try and update everything just be sure you have the latest version of all files.

Posted: Mon Dec 20, 2010 3:44 pm
by tswita662
I'm installing from a CD. Have uninstalled and reinstalled several times, but no luck. Tried install with Virus software disabled. Still did not work. Vista Operating system.

Posted: Mon Dec 20, 2010 4:14 pm
by pipfromslitherine
Please post the error.log immediately after the game crashes. This can be found in the Documents\My Games\BBCBA folder, and we will try and work out what the issue is.

Cheers

Pip

Posted: Wed Dec 22, 2010 1:46 am
by tswita662
Pip,

Everything seems to be working now, except when I start game, it keeps asking me to load the latest update. I click yes and nothing happens? Also I tried to delete the V.txt file as you suggested and I get a message telling me that "access is denied, because the file is in use by a different program? Because I can't install the update, I can't connect to the server? Tried to install more then once with virus software disabled. Any ideas on how to let the program know it is updated?

Posted: Wed Dec 22, 2010 3:02 am
by pipfromslitherine
There is actually a new version available, 1.5.1. My guess is that you haven't allowed the new updater (it's called UPDATER2.EXE, and was added in 1.4) through your firewall, and it's being blocked?

Cheers

Pip

Posted: Wed Dec 22, 2010 3:14 am
by pipfromslitherine
If you don't have an UPDATER2.EXE in your game folder, please see this forum post for a solution:

viewtopic.php?t=20783

Cheers

Pip

Posted: Thu Dec 23, 2010 4:27 pm
by tswita662
Tried dropping in the updater2.exe as you suggested, but all I got was a version mismatch (0) and had to re-install the game. Still have same problem of connecting to server and still asking to update to latest version. The loading screen shows Build 1.5.0 as the current version.

Posted: Thu Dec 23, 2010 4:32 pm
by pipfromslitherine
You can grab a 1.5.1 update installer to solve this issue. I would recommend a reinstall the main game, then apply the 1.5.1 patch. I'm not sure how you could get a version mismatch, that can only happen if somehow the EXE and some of the versioning info were out of sync, meaning only half the update was applied.

You can find the 1.5.1 installer here:

http://www.slitherine.com/files/bbc_ba/ ... v1.5.1.exe

Cheers

Pip

Posted: Mon Dec 27, 2010 10:07 pm
by tswita662
Pip,

Thanks for your help with this problem. It appears that the latest update 1.5.1 fixed everything I was having a problem with and I didn't even need to do an uninstall prior to running the file.