Can PC 4.00 play Mac 4.029?

PSP/DS/PC/MAC : WWII turn based grand strategy game

Moderators: firepowerjohan, rkr1958, Happycat, Slitherine Core

Post Reply
chrisfso
Corporal - 5 cm Pak 38
Corporal - 5 cm Pak 38
Posts: 41
Joined: Sun Jun 08, 2014 10:53 pm

Can PC 4.00 play Mac 4.029?

Post by chrisfso » Sun Jan 14, 2018 9:30 pm

My Axis opponent has Windows running version 4.00 and I am playing Allies with a Mac running 4.029. As I understand it, 4.029 is a special Mac-only update to fix the automatic password problem. When I try to load my opponent's first turn, it refuses to load and gives the error message "exception - this game was saved in a previous version of the game and cannot be loaded." Does my Mac 4.029 think that a Windows 4.00 is a previous version of the game? What are we doing wrong?
Thanks,
Chris

pk867
Sr. Colonel - Battleship
Sr. Colonel - Battleship
Posts: 1601
Joined: Fri May 08, 2009 3:18 pm

Re: Can PC 4.00 play Mac 4.029?

Post by pk867 » Mon Jan 15, 2018 12:09 am

Who started the game, you as the Axis or the PC player?

Maybe he sent the wrong file? If he uses a common name for the file name that can always happen.

The game was and has been designed to play cross- platform since version 2.0 was released that has not changed.

The Mac version 4.029 was the last version before being released. The PC version 4.0 has the same options using

automatic password. The error you are getting is that the game started on your opponents machine was not started with the final version.

We released a pre-release version last year called v4.00 in January 2016 which is not compatible at all with the version released in December 2017.

I am currently playing a player who uses a PC and the game plays fine.

The Mac version v4.029 is a separate app and does not need to be copied over into any previous versions of the CEAW-GS for Mac like the PC players need to do until

Slitherine makes an installer. I would guess the PC version is the culprit, but why it is I can not say right now. Maybe the PC player needs to try and start over doing

a fresh install and see if that fixes the problem. The player starting the game ie Axis, should start a new game anyways just to be sure.

chrisfso
Corporal - 5 cm Pak 38
Corporal - 5 cm Pak 38
Posts: 41
Joined: Sun Jun 08, 2014 10:53 pm

Re: Can PC 4.00 play Mac 4.029?

Post by chrisfso » Mon Jan 15, 2018 8:31 pm

The PC player started the game as Axis and sent me his first turn. I suggested he do a fresh install. I want to make sure the problem is not somehow on my Mac. Can I email you the first turn he sent me to see if you can load it and play the Allied first turn? If so, please PM me your email address. Thanks. Chris

pk867
Sr. Colonel - Battleship
Sr. Colonel - Battleship
Posts: 1601
Joined: Fri May 08, 2009 3:18 pm

Re: Can PC 4.00 play Mac 4.029?

Post by pk867 » Tue Jan 16, 2018 9:25 am

I sent a pm

bart74
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 3
Joined: Tue Dec 22, 2015 9:46 am

Re: Can PC 4.00 play Mac 4.029?

Post by bart74 » Tue Jan 16, 2018 12:50 pm

Hello,
If i have a manual password not automatic for PBEM games, could this cause a problem?
I think i have latest version, with new OdB for France and new unit in Poland in Lodz.

Peter Stauffenberg
General - Carrier
General - Carrier
Posts: 4710
Joined: Sun Jul 08, 2007 4:13 pm
Location: Oslo, Norway

Re: Can PC 4.00 play Mac 4.029?

Post by Peter Stauffenberg » Tue Jan 16, 2018 7:11 pm

Do you get an option to select automatic or manual password? If not you have an old version. You need to install v4.029

pk867
Sr. Colonel - Battleship
Sr. Colonel - Battleship
Posts: 1601
Joined: Fri May 08, 2009 3:18 pm

Re: Can PC 4.00 play Mac 4.029?

Post by pk867 » Tue Jan 16, 2018 7:27 pm

You can have manual passwords, as long as you do not install Mac OS High Sierra 10.13.2 .

If you do you can not enter in passwords or create names for Saved AI and HotSeat games.

Automatic is easy. So once you have finished older versions of the game, before you start a new one,

delete the GS400_settings.txt file in Documents\Grand Strategy v400 folder. Then select Automatic passwords.

robertcomposer
Lance Corporal - Panzer IA
Lance Corporal - Panzer IA
Posts: 17
Joined: Sat Jan 08, 2011 10:13 pm

Re: Can PC 4.00 play Mac 4.029?

Post by robertcomposer » Wed Sep 12, 2018 8:51 pm

I have updated to 4.0 for Mac - but when I try to save it will not let me. No problem in previous versions. Suggestions?

Post Reply

Return to “MILITARY HISTORY™ Commander - Europe at War : General Discussion”