Multiplayer still crashes

Close Combat - Gateway to Caen : Tech Support

Moderators: Pandora Moderators, Slitherine Core

Post Reply
major_rud
Private First Class - Wehrmacht Inf
Private First Class - Wehrmacht Inf
Posts: 8
Joined: Thu Nov 29, 2012 9:14 am

Multiplayer still crashes

Post by major_rud » Wed Jan 20, 2016 8:56 pm

Hi Steve and all it might concern,

Me and my friend have been playing Close combat multi player since the since CC 4. I my self have bought every CC games since Close Combat 1.

When it runs and works fine i still believe that CC is the most realistic and challenging game there is and in my opinion it is developed as a multi player game and not as a single player game since the AI always have been rubbish.

My problem is recently we tried to give Caen a second chance we thought that now, a game that's been on the market for almost two years must be fully up and running, all issues fixed with patches and updates. We sadly still have the issue that the game is extremely unstable in multi player and the games breaks down or one of us are disconnected... I am extremely disappointed. People pay big money for a game and expect it to work... We have not received any value for our money.

Of cause it might be that one or both of us is doing something wrong. In which case I would like to apologise for my comment and ask for assistance so we can have the game work on our pcs.

In any case next time you release a new Close Combat let it run as a beta, so when people buy the alpha the game will run stable. This is what you expect when you buy a product.

Looking forward to hear from you.
A CC fan

Housies
Lance Corporal - Panzer IA
Lance Corporal - Panzer IA
Posts: 17
Joined: Sun Dec 22, 2013 12:54 pm

Re: Multiplayer still crashes

Post by Housies » Thu Jan 21, 2016 9:14 am

Same thing here. Tried connecting to another player 3 times but we timed out on each occasion and received the connection lost message.

SteveMcClaire
Matrix
Matrix
Posts: 133
Joined: Fri Apr 27, 2012 2:48 pm

Re: Multiplayer still crashes

Post by SteveMcClaire » Thu Jan 21, 2016 9:23 pm

major_rud wrote:Hi Steve and all it might concern,
My problem is recently we tried to give Caen a second chance we thought that now, a game that's been on the market for almost two years must be fully up and running, all issues fixed with patches and updates. We sadly still have the issue that the game is extremely unstable in multi player and the games breaks down or one of us are disconnected... I am extremely disappointed. People pay big money for a game and expect it to work... We have not received any value for our money.
That does sound frustrating -- the game is generally stable in multiplayer, so I'm not sure what is causing the issue you are seeing, but there have been several updates since release. I would recommend making sure you and your opponent both have the latest patches (available from www.matrixgames.com or applied automatically if you're using the Steam version of the game) and that you're playing without any mods to the base game.

A couple of other things to try:

* Start a brand new game. If this is an old saved game file it is possible the file is corrupted somehow.

* Have the host player open their firewall / router for incoming connections on the game port 1944. This will allow the client to make a direct connection to the host machine and avoid the overhead of using the Slitherine routing servers. If this is successful you will see "DIRECT CONNECTION" on the Multi-player screen after connecting to your opponent. If not, it will say "LOBBY CONNECTION."

* Shut down as many other network-intensive apps on your machines as you can, and be sure no one else is running a large download / upload, just to make sure bandwidth isn't an issue.

* Try temporarily turning off any security / anti-virus software, just to be sure it's not blocking connections for some reason.

* Switch which of you is hosting and who is joining and see if that makes a difference.

* Try playing single battles instead of a campaign or operation -- the amount of data exchanged is much less and if you are reliably able to play a battle but not a large campaign there may be a reliability / throughput issue.

* Try connecting to other players to see if it is something specific between you and your current opponent.

If none of these help us narrow down the source of the problem, we can start looking at your Windows version or other configuration-related issues.

Thanks,

Steve

Steve

major_rud
Private First Class - Wehrmacht Inf
Private First Class - Wehrmacht Inf
Posts: 8
Joined: Thu Nov 29, 2012 9:14 am

Re: Multiplayer still crashes

Post by major_rud » Sat Jan 23, 2016 8:32 pm

Wow thats a lot of things one have to do to run this game in MP... But whatever we need, we'll do....

It was a new game and we do both have steam and no mods. So guess newest patch...

* Have the host player open their firewall / router for incoming connections on the game port 1944. - port 1944? Don't know what this means.... In the old CC games we could play MP if we used Hamachi. With other games we play MP we don't have any problems. So I'm not aware what it means...

SteveMcClaire
Matrix
Matrix
Posts: 133
Joined: Fri Apr 27, 2012 2:48 pm

Re: Multiplayer still crashes

Post by SteveMcClaire » Thu Jan 28, 2016 5:52 pm

To clarify, I posted a list of possible troubleshooting steps. None of these are 'necessary' to play the game multi-player in most cases. It's not a list of 'try all these at once' but rather a list of things to try one at a time and check the results, in an attempt to narrow down the source of the problem.

Hamachi is a relay service that acts much like the current Gateway to Caen lobby system, and both avoid the need for an inbound connection and opening ports in your router/firewall. I suggested you try a direct connection to see if this improves performance and reliability for you and your opponent, but doing this is a bit technical if you're not familiar with the process. Here is an article on the general procedure -- I am sure you can find others more specific to your router via Google:

http://www.pcworld.com/article/244314/h ... outer.html

Did you try any of the other steps I suggested, and what were the results if so?

Thanks,

Steve

Post Reply

Return to “Close Combat - Gateway to Caen : Tech Support”