Strange occurence at beginning of mp game

Moderators: rbodleyscott, Slitherine Core, Gothic Labs

Post Reply
ahuyton
Staff Sergeant - Kavallerie
Staff Sergeant - Kavallerie
Posts: 316
Joined: Sun Jun 17, 2007 4:31 pm

Strange occurence at beginning of mp game

Post by ahuyton » Sat Jul 14, 2018 4:56 pm

I joined a multiplayer game. On my deployment turn, I had an endless loop as follows:
- message that I was in deployment mode
- before I could do anything, message that I was victorious
- message screen, which I duly completed assuming an error somewhere
- I send to server
- message that it is impossible to send to server and to retry turn

I tried three times,with the same results before cancelling the turn.

I will try again later but do not want to have it recorded that I am forever cancelling my turn. Any thoughts?

Alan

zakblood
Most Active User 2017
Most Active User 2017
Posts: 15415
Joined: Thu Jun 12, 2014 6:44 pm

Re: Strange occurence at beginning of mp game

Post by zakblood » Sat Jul 14, 2018 5:00 pm

only thought i have is it's a custom battle or both on different versions regarding patches etc maybe?

Manstein63
Lance Corporal - Panzer IA
Lance Corporal - Panzer IA
Posts: 10
Joined: Thu Dec 09, 2010 10:00 pm

Re: Strange occurence at beginning of mp game

Post by Manstein63 » Sat Jul 14, 2018 7:33 pm

This is the same issue that I reported although ahuyton put it much better than I did

rbodleyscott
Field of Glory 2
Field of Glory 2
Posts: 22231
Joined: Sun Dec 04, 2005 6:25 pm

Re: Strange occurence at beginning of mp game

Post by rbodleyscott » Mon Jul 16, 2018 1:24 pm

The usual reason for this sequence of in-game messages to occur is if one side's army has not been initialised correctly, so it has no units on the map. This is usually due to the challenge data having a name string for the army list which does not match the "chunk name" in the army list file.

Obviously this should not happen, unless either player is using a modded army list file. (And both are not using the same modded version, from start to finish).

However, PBEM has recently migrated to a new server, requiring the server code to be rewritten, so it is possible that something in the army list name is causing some army list strings not to be transferred correctly to and from the server.

Can you tell me which were the army lists specified as having "lost" in each of these battles, and which skirmish module they are from?

Also, what proportion of your skirmish games is this issue occurring in?

Has it occurred in any preset scenario games?
Richard Bodley Scott

Image

ahuyton
Staff Sergeant - Kavallerie
Staff Sergeant - Kavallerie
Posts: 316
Joined: Sun Jun 17, 2007 4:31 pm

Re: Strange occurence at beginning of mp game

Post by ahuyton » Mon Jul 16, 2018 7:09 pm

Richard, thanks for this.

It is only happening in one game, and this is the first time for me. I have played other skirmish games and scenarios in the last couple of months without similar incidents. My opponent selected the army lists, with default selection, which are:
- Ottoman Turkish 1494-1559 (mine)
- Russian 1550-1559 (lost)

ahuyton
Staff Sergeant - Kavallerie
Staff Sergeant - Kavallerie
Posts: 316
Joined: Sun Jun 17, 2007 4:31 pm

Re: Strange occurence at beginning of mp game

Post by ahuyton » Sun Jul 22, 2018 8:37 am

Would it be possible to delete this game from the server please, ahuyton v waterhead1985? Thanks

rbodleyscott
Field of Glory 2
Field of Glory 2
Posts: 22231
Joined: Sun Dec 04, 2005 6:25 pm

Re: Strange occurence at beginning of mp game

Post by rbodleyscott » Mon Jul 23, 2018 7:11 am

ahuyton wrote:
Sun Jul 22, 2018 8:37 am
Would it be possible to delete this game from the server please, ahuyton v waterhead1985? Thanks
Whoever's turn it isn't can delete it after there is no activity for 7 days.
Richard Bodley Scott

Image

Post Reply

Return to “Tech Support”