Star Wars: Alliance Mod known bugs

Polaris Sector is a sci-fi 4X game that offers exciting exploration, detailed resource management, unique research mechanics and intense tactical combat.
Post Reply
Babjatekos
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 3
Joined: Sat Jul 16, 2016 7:30 pm

Star Wars: Alliance Mod known bugs

Post by Babjatekos » Sat Jul 16, 2016 7:45 pm

A few bugs were found in the mod:

1.) If load a save game, any heroes which are moved away from his/her home planet are missing. Doesn't matter he/she standing on his/her ship or other ship or planet.

2.) With the Rebels ship type: Quasar when trying to make any kind of ship designs from it, the plans are works fine till quit the game, and reload the save game. Then all the saved desing is transfered to the Rebels Gunship.

3.) starting with the Black Sun, clicking to the starting planet - want to get to the planet screen view - crashes the game

Firefox440
2nd Lieutenant - Panzer IVF/2
2nd Lieutenant - Panzer IVF/2
Posts: 682
Joined: Fri Jun 06, 2014 11:58 pm
Contact:

Re: Star Wars: Alliance Mod known bugs

Post by Firefox440 » Sun Jul 17, 2016 12:12 am

Thanks to the gods, I have found all the errors easily with exception from the error where heroes dissapeared. With exception from the heroes dissapeared, probably it is error in the game code and I can not fix it by myself. I will release soon (today) a new patch. In addition, I have added all the images from factions, ground units and more added in the mod improved with reduction in their sizes. I will save some of memory.

Firefox440
2nd Lieutenant - Panzer IVF/2
2nd Lieutenant - Panzer IVF/2
Posts: 682
Joined: Fri Jun 06, 2014 11:58 pm
Contact:

Re: Star Wars: Alliance Mod known bugs

Post by Firefox440 » Sun Jul 17, 2016 12:35 am

1.) If load a save game, any heroes which are moved away from his/her home planet are missing. Doesn't matter he/she standing on his/her ship or other ship or planet.
With what faction did you see it? by the moment I could not replicate the problem.

Babjatekos
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 3
Joined: Sat Jul 16, 2016 7:30 pm

Re: Star Wars: Alliance Mod known bugs

Post by Babjatekos » Sun Jul 17, 2016 7:08 am

Nomada_Firefox wrote:
1.) If load a save game, any heroes which are moved away from his/her home planet are missing. Doesn't matter he/she standing on his/her ship or other ship or planet.
With what faction did you see it? by the moment I could not replicate the problem.
Playing as Republic I found Padme and Obivan, I put Padme on her ship and moved her to Obivan location, after I moved them togather and after a save and later a load they gone... they disappeared as if they never existed, but Padme's ship still exist.

If I dont move them away from the planet they were found, they gonna exist as long as they stay there.


Edit:

Empire heroes are gone missing too..

Firefox440
2nd Lieutenant - Panzer IVF/2
2nd Lieutenant - Panzer IVF/2
Posts: 682
Joined: Fri Jun 06, 2014 11:58 pm
Contact:

Re: Star Wars: Alliance Mod known bugs

Post by Firefox440 » Sun Jul 17, 2016 8:57 am

Empire heroes are gone missing too..
My point is this. I do not go to lie you. I have not played too much with the Republic but I have played a lot with the Empire and I have not seen this problem.

Are you sure how you are playing with the 1.04b or 1.04c versions from the game? the mod will not run at 100% with other previous versions. Have you selected the English language? The mod has not been translated to other languages and it will not run with other language selected at 100%.

I do not know. At the end, I can not replicate the problem.

Babjatekos
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 3
Joined: Sat Jul 16, 2016 7:30 pm

Re: Star Wars: Alliance Mod known bugs

Post by Babjatekos » Sun Jul 17, 2016 9:10 am

Nomada_Firefox wrote:
Empire heroes are gone missing too..
My point is this. I do not go to lie you. I have not played too much with the Republic but I have played a lot with the Empire and I have not seen this problem.

Are you sure how you are playing with the 1.04b or 1.04c versions from the game? the mod will not run at 100% with other previous versions. Have you selected the English language? The mod has not been translated to other languages and it will not run with other language selected at 100%.

I do not know. At the end, I can not replicate the problem.
I use 1.04c version...
By the way I not realy use heroes :D so I dont realy care they works normaly or not, its not realy a game or mod breaking bug in my eyes. :)
I just reported the problem what I found, and maybe shortly I reinstall the whole game and mod, just to be sure this bug exist or not...

Firefox440
2nd Lieutenant - Panzer IVF/2
2nd Lieutenant - Panzer IVF/2
Posts: 682
Joined: Fri Jun 06, 2014 11:58 pm
Contact:

Re: Star Wars: Alliance Mod known bugs

Post by Firefox440 » Wed Jul 20, 2016 10:33 pm

Babjatekos wrote:
Nomada_Firefox wrote:
Empire heroes are gone missing too..
My point is this. I do not go to lie you. I have not played too much with the Republic but I have played a lot with the Empire and I have not seen this problem.

Are you sure how you are playing with the 1.04b or 1.04c versions from the game? the mod will not run at 100% with other previous versions. Have you selected the English language? The mod has not been translated to other languages and it will not run with other language selected at 100%.

I do not know. At the end, I can not replicate the problem.
I use 1.04c version...
By the way I not realy use heroes :D so I dont realy care they works normaly or not, its not realy a game or mod breaking bug in my eyes. :)
I just reported the problem what I found, and maybe shortly I reinstall the whole game and mod, just to be sure this bug exist or not...
I see the bug playing today but..........I can not fix it by myself. It is a problem from the game code. Ufnv (the creator from the game) is the unique who he can fix it.

peterw
Senior Corporal - Destroyer
Senior Corporal - Destroyer
Posts: 103
Joined: Fri Apr 25, 2014 7:08 am

Re: Star Wars: Alliance Mod known bugs

Post by peterw » Mon Aug 01, 2016 1:16 pm

I checked yesterday the heroes too (with P.S. V1.04c) and got two problems:

1. The heroes disappears after I re-load a save game, if I allocates them to a ship.
If I relocate them to another planed they stay (at this new planet).

2. It seems the heroes don't generate a bonus. At least the production heroes don't speed up the production.
As I lost the heroes which provide a bonus for ships, I can't check it now.


edit:
3) The weapons of the Ancient Prior don't fire independent of the direction (at the standard game some fire at a 90° degree, others at 360°).
And in opposite of all my other ships no range is shown for it's weapons.
The shield and hit-point worked normally.
Because of this I allowed the opponent to destroy this ship.
(I play actually as Rebels.)
My Italian Panzer Corps campaign Italia Victor!:
http://www.streitmacht.com/downloads.php?view=detail&df_id=53

Firefox440
2nd Lieutenant - Panzer IVF/2
2nd Lieutenant - Panzer IVF/2
Posts: 682
Joined: Fri Jun 06, 2014 11:58 pm
Contact:

Re: Star Wars: Alliance Mod known bugs

Post by Firefox440 » Wed Aug 03, 2016 9:48 am

[quote="peterw"
1. The heroes disappears after I re-load a save game, if I allocates them to a ship.
If I relocate them to another planed they stay (at this new planet).[/quote]
Ufnv knows about it. I can not make nothing for fix it. It is a matter from the heroes code in the game.
2. It seems the heroes don't generate a bonus. At least the production heroes don't speed up the production.
As I lost the heroes which provide a bonus for ships, I can't check it now.
I do not think so. I have tested it and it runs. Just it is not a very big reduction.
edit:
3) The weapons of the Ancient Prior don't fire independent of the direction (at the standard game some fire at a 90° degree, others at 360°).
And in opposite of all my other ships no range is shown for it's weapons.
The shield and hit-point worked normally.
Because of this I allowed the opponent to destroy this ship.
(I play actually as Rebels.)
What unit is the Ancient Prior? it is a SW mod.;)

peterw
Senior Corporal - Destroyer
Senior Corporal - Destroyer
Posts: 103
Joined: Fri Apr 25, 2014 7:08 am

Re: Star Wars: Alliance Mod known bugs

Post by peterw » Thu Aug 04, 2016 7:49 am

I checked the heroes with production bonus again.
Yes, it really speeds up the production of units.
But the ETA time is the one without the bonus. That's why I originally don't recognized it.

And I found one funny fact:
If I use the food reduction policy the production time is normally much longer (3 times?).
But with my 3 production bonus heroes it's much faster. It seems the bonus is independent of the policy.
In this way I was able to stay with food reduction policy and saved a lot of food this way (this planet was the one with most population).
My Italian Panzer Corps campaign Italia Victor!:
http://www.streitmacht.com/downloads.php?view=detail&df_id=53

crimsonsun
Lance Corporal - Panzer IA
Lance Corporal - Panzer IA
Posts: 16
Joined: Tue Oct 07, 2014 6:49 am

Re: Star Wars: Alliance Mod known bugs

Post by crimsonsun » Thu Aug 18, 2016 7:47 pm

This mod seems extensive and shows a lot of work as gone into it but I was forced to stop playing as I found some annoying issues, though in retrospect they may have been my own fault as I've not seen anywhere confirming if it works with the current 1.5 beta or not. My main issues were that I could not build transports for heroes which just never showed up after I researched them. I was also utterly confused as to what the different colours of laser weapons brought to the table many seemed to have identical statistics and the enemy were wiping the flaw with me using ion cannons and core game techs. Anyway I'll come back to it at some point I'm sure though I'll likely run it via an independent installation so I can continue to play the main game at the same time.

Firefox440
2nd Lieutenant - Panzer IVF/2
2nd Lieutenant - Panzer IVF/2
Posts: 682
Joined: Fri Jun 06, 2014 11:58 pm
Contact:

Re: Star Wars: Alliance Mod known bugs

Post by Firefox440 » Fri Aug 19, 2016 11:20 am

It should work with the 1.5. But there is not way where I can fix the problems by myself if they were nof fixed in the patch.

The matter of colors from weapons is a thing from Star Wars, each faction used a main color for the turbolaser.

Post Reply

Return to “Polaris Sector”