1.09 Bug: Supply from helo not reaching FOB after "continue"

Afghanistan '11 changes the paradigm of wargaming and manages to bring Counter-Insurgency and guerrilla warfare to your screen, properly represented thanks to a revolutionary gameplay formula!
Post Reply
Tomcat84
Private First Class - Wehrmacht Inf
Private First Class - Wehrmacht Inf
Posts: 7
Joined: Sat Oct 05, 2013 7:30 pm

1.09 Bug: Supply from helo not reaching FOB after "continue"

Post by Tomcat84 » Thu Apr 20, 2017 2:35 pm

100% reproducable for me with attached savegame.

Situation:
I have a single Chinook (Bull 01). I have ordered this Chinook in the previous turn to depart my HQ with supplies to go resupply my FOB to the east. Now in the current turn of the savegame, if I manually click the Chinook and order it to resupply the FOB, the FOB resupplies from 3/5 to 5/5 and all is well. But if instead of doing it manually, I click continue (since I ordered it to do the resupply in the previous turn and it is on its way), the Chinook (with the supplies underslung) flies to the FOB, lands there (costing fewer PP by the way than in the previous case), the supplies vanish and the FOB is not resupplied.

I have not tested if this also happens with:
- ammo
- trucks
- Mi-8s / Blackhawks with ammo

Let me know if this is unclear. Haven't tested in 1.08 sorry.

edit: still happening in 1.09
Attachments
chinookfobsupplyissue.zip
(14.67 KiB) Downloaded 56 times
Last edited by Tomcat84 on Thu Apr 20, 2017 8:10 pm, edited 1 time in total.

zakblood
Most Active User 2017
Most Active User 2017
Posts: 15778
Joined: Thu Jun 12, 2014 6:44 pm

Re: 1.07 Bug: Supply from helo not reaching FOB after "conti

Post by zakblood » Thu Apr 20, 2017 2:43 pm

thanks for the save for the developers, it maybe something already fixed in the latest update

http://www.slitherine.com/forum/viewtop ... 42&t=76981

Tomcat84
Private First Class - Wehrmacht Inf
Private First Class - Wehrmacht Inf
Posts: 7
Joined: Sat Oct 05, 2013 7:30 pm

Re: 1.07 Bug: Supply from helo not reaching FOB after "conti

Post by Tomcat84 » Thu Apr 20, 2017 3:08 pm

I considered that possibility but I did not think anything in the changelog was really related to this so I still posted it. I just tried to load the 1.08beta in order to check but the savegame wont load in that, gives an error.

Additional similar issue was noticed with UN aid. Have another save game attached to this post.

If you hit continue, one supply truck RTBs to the HQ, the second supply truck with UN aid delivers it to a nearby village. There is no "UN aid delivered" audio, and the flag stays an ANA flag.

If you reload it and manually deliver the UN supplies, the village gains a US flag.

When 1.09 comes out (I hope soon!) I will try to setup a similar situation and test (unless the dev beats me to it :)) and see if it is still a factor in the latest versions.
Attachments
unaidissue.zip
(16.6 KiB) Downloaded 60 times

Tomcat84
Private First Class - Wehrmacht Inf
Private First Class - Wehrmacht Inf
Posts: 7
Joined: Sat Oct 05, 2013 7:30 pm

Re: 1.09 Bug: Supply from helo not reaching FOB after "conti

Post by Tomcat84 » Thu Apr 20, 2017 8:11 pm

Tested in 1.09. Both savegames still showing this behavior. The only difference I can tel is that there is no variation in the PP cost for the Chinook movement. They are now both at 80 (instead of the "continue" movement only costing 40) but there is still no supply adding up for the FOB when using "continue".

Every Single Soldier
Vietnam ’65 developer
Vietnam ’65 developer
Posts: 1770
Joined: Wed Jan 14, 2015 4:40 pm

Re: 1.09 Bug: Supply from helo not reaching FOB after "conti

Post by Every Single Soldier » Mon Apr 24, 2017 5:34 pm

Will check it out .... :shock:

Post Reply

Return to “Afghanistan '11”