Disable smooth scrolling of the map?

Post Reply
JPJ
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 4
Joined: Fri Oct 13, 2017 2:10 pm

Disable smooth scrolling of the map?

Post by JPJ » Fri Jan 19, 2018 11:42 am

I am new to this game.
Is it possible to disable the "smooth scrolling" feature of the map?

When I click the arrow keys to scroll, the map starts moving slowly, then accelerates, and slows down again before stopping. I don't like that at all -- I want the map to move instantly when I click the arrow keys.

Game version = 1.1.8, monitor 1920x1080, Windows 10. Lower screen resolutions and lowering the video quality did not change that behaviour. And it seems the Pan speed slide bar only sets the scrolling speed but does not disable that "smooth" scrolling.

Incidentally, I noticed the game entry in the Windows registry (under HKEY_CURRENT_USER\Software\Every Single Soldier\Afghanistan '11) lists the PanSpeed key has an "invalid DWORD (32-bit) value". I don't know whether that is related to this at all though.

Sorry if this has been asked already. I did not find a solution.

zakblood
Most Active User 2017
Most Active User 2017
Posts: 15446
Joined: Thu Jun 12, 2014 6:44 pm

Re: Disable smooth scrolling of the map?

Post by zakblood » Fri Jan 19, 2018 12:07 pm

welcome to the board and forum and sorry JPJ for your issues, again this is one of the developer as it's not something i can answer, but welcome you all the same so you know your post has been seen but not yet answered

JPJ
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 4
Joined: Fri Oct 13, 2017 2:10 pm

Re: Disable smooth scrolling of the map?

Post by JPJ » Wed Feb 07, 2018 9:12 am

There is no answer yet.
Does that mean the developer does not support this forum any longer?

Unfortunately, the jerky smooth scrolling in the game gives me motion sickness and makes the game unplayable for me.

Adjusting the frame rate also did not improve this for me. I suspect the problem is not my graphics (Field of Glory 2, Sengoku Jidai, Distant Worlds Universe perform well on this machine and I have no motion sickness) but this game's particular map scrolling animation. I did not notice that in previews and wish you could switch this scrolling animation off.

zakblood
Most Active User 2017
Most Active User 2017
Posts: 15446
Joined: Thu Jun 12, 2014 6:44 pm

Re: Disable smooth scrolling of the map?

Post by zakblood » Wed Feb 07, 2018 9:32 am

lets take it further and see what spec you have and then i'll send them a note for a reply, if that's ok with you?

How to get a DirectX Diagnostic file:

1. click on "START"
2. click "run"
3. type in "dxdiag" and click "OK"
4. check through the tabs and perform all tests
5. click "Save all Information..." and save the text file to a location of your choice

We prefer that DxDiag files be posted as message attachments rather than pasted into the body of the post.

once the report has been made, just attach it to your post with first adding the file to a zip, which is then permitted to attach to the forum


as the issue sounds more of a performance issue than a pure gaming tech bug type one

JPJ
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 4
Joined: Fri Oct 13, 2017 2:10 pm

Re: Disable smooth scrolling of the map?

Post by JPJ » Wed Feb 07, 2018 12:53 pm

Thanks for looking into this. DxDiag attached.
zakblood_slith wrote: as the issue sounds more of a performance issue than a pure gaming tech bug type one
I don't think the way the map scrolls is a bug but by design. I have tried from the highest to the lowest video quality settings and various settings and fps in the Radeon OverDrive settings, but they don't seem to affect how the map scrolls.

I have no graphics glitches or lagging or stuttering; but it is how the map accelerates and decelerates when scrolling. That "smoothing" effect looks great if you like it but I would like there to be an option to switch it off (similar to the option to disable smooth scrolling in browsers).
Last edited by JPJ on Sat Mar 03, 2018 1:12 am, edited 1 time in total.

zakblood
Most Active User 2017
Most Active User 2017
Posts: 15446
Joined: Thu Jun 12, 2014 6:44 pm

Re: Disable smooth scrolling of the map?

Post by zakblood » Wed Feb 07, 2018 12:55 pm

ok thanks, looking now and will pass it on to the developers

zakblood
Most Active User 2017
Most Active User 2017
Posts: 15446
Joined: Thu Jun 12, 2014 6:44 pm

Re: Disable smooth scrolling of the map?

Post by zakblood » Wed Feb 07, 2018 1:06 pm

and here my opinion and findings on what i see and found,

avguard.exe which is part of the avira anti virus program is known to half the cpu of some machines as it contantly scans in the background and stops some apps from working correctly altogether

P1: Microsoft Corporation.BlueScreenDiagnostic.1.1 is a major windows system error and is logged in your report twice, this can be something as easy as a bad driver and once updated to it working correctly or a bad or missing system file, either way, as system scan is recommend to fully check this or these error are no longer around.

avguard.exe has caused more than a few errors from your logs (Naam van gebeurtenis: RADAR_PRE_LEAK_WOW64)

so next question is,

is this an upgrade to windows 10 or a clean install?

have you any others errors on the system? or only in this game?

for me check the error logs in the AV product, my opinion of it, is it's a poor gaming AV program and you may be better over with out and using the default one which comes with windows, built in and also free and with less errors, the other is run a system scan in windows 10 and check it for system errors.

and see if that sorts the game out for you,

Code: Select all

https://support.microsoft.com/en-gb/help/4026529/windows-10-using-system-file-checker
System File Checker is a utility available in Windows 10 that checks for system file corruption. It's recommended for advanced users. To run it:

Select Start , and in the search box, enter Command Prompt. Press and hold (or right-click) Command Prompt (Desktop app) from the search results and select Run as administrator.

Enter DISM.exe /Online /Cleanup-image /Restorehealth (note the spaces before each "/").

Enter sfc /scannow (note the space between "sfc" and "/").
check your system with the game running for high cpu use with the AV program and make your own mind up if you wish to carry on using it, if so, eg yes, then add a except to the rules on the game, so it's not scanned during or at startup etc

Code: Select all

https://blog.avira.com/exceptions-avira-antivirus-3-steps/
good luck and hope something here helps

JPJ
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 4
Joined: Fri Oct 13, 2017 2:10 pm

Re: Disable smooth scrolling of the map?

Post by JPJ » Wed Feb 07, 2018 1:50 pm

Thanks.
This is a clean Windows 10 install, not an upgrade.
This program is listed as an exception in Avira.
I am aware of the Blue Screen error; I suspect another process causing that.
Drivers should be up to date. And I am aware of the System File Checkers; they return no problems.
zakblood_slith wrote: have you any others errors on the system? or only in this game?
No. Not at all.
Again, I do no think it is an error in the game. The smooth scrolling effect (with acceleration and deceleration of the map) looks perfectly correct to me.

But I wondered if there is a possibility to switch that effect OFF (= scroll the map "normally" without smoothing effects) because for me personally seeing this effect all the time causes motion sickness after a while. I take it that is not possible.

zakblood
Most Active User 2017
Most Active User 2017
Posts: 15446
Joined: Thu Jun 12, 2014 6:44 pm

Re: Disable smooth scrolling of the map?

Post by zakblood » Wed Feb 07, 2018 2:13 pm

not that i know of, i will contact the developer and ask and post a reply asap

Post Reply

Return to “Afghanistan '11: Tech Support”