Info sent if pre-open crash?

Post Reply
lordhoff
Corporal - Strongpoint
Corporal - Strongpoint
Posts: 66
Joined: Tue Aug 04, 2009 7:31 am

Info sent if pre-open crash?

Post by lordhoff » Tue Feb 26, 2019 1:57 am

I'm no longer able to open the game - the crash box (to send information/e-mail) pops up when "play game" is used. Now I'm wondering, since the game doesn't open, does the save file, etc even get sent? Should I do something else to try to get the game working again?

zakblood
Most Active User 2017
Most Active User 2017
Posts: 15441
Joined: Thu Jun 12, 2014 6:44 pm

Re: Info sent if pre-open crash?

Post by zakblood » Tue Feb 26, 2019 6:31 am

just uninstall the game, make sure the folder is empty and reinstall and patch to the latest version, this will install everything which is needed for the game to run, just remember to install as admin and run as admin

http://www.slitherine.com/forum/viewtop ... 28&t=87622

pavelk
Kubat Software
Kubat Software
Posts: 2445
Joined: Mon May 16, 2016 4:27 pm

Re: Info sent if pre-open crash?

Post by pavelk » Tue Feb 26, 2019 9:03 am

lordhoff wrote:
Tue Feb 26, 2019 1:57 am
I'm no longer able to open the game - the crash box (to send information/e-mail) pops up when "play game" is used. Now I'm wondering, since the game doesn't open, does the save file, etc even get sent? Should I do something else to try to get the game working again?
Hello lordhoff,
what was the last thing you have done when the game was running? Is there any chance you installed a custom mod? We havent received any reports from you (in last couple of days) so it doesn't seem like it went through. Could you please send me both aggressors.log and error.log files to my email? We will sort it out.

lordhoff
Corporal - Strongpoint
Corporal - Strongpoint
Posts: 66
Joined: Tue Aug 04, 2009 7:31 am

Re: Info sent if pre-open crash?

Post by lordhoff » Wed Feb 27, 2019 4:13 am

It was a few days ago so my memory is foggy but, I believe I was playing another game, closed it down, then tried to open AAR. I tried again with the same result (clicked on "play game"). Both times I typed in some text in the report error box (upper right click), provided e-mail address, and checked "send saved game". I may have done some routine surfing between games. The next day, I tried again with the same result and another attempt to send the error report.

No mods were used - not even the map editor.

Both logs (dated 2/24/19) were sent - interesting that the ones in Kubat software (C:\Program Files (x86)\Kubat Software\Aggressors Ancient Rome\ProgramData) had 0 bytes as the size for both. I tried opening the game again, clicked on the middle icon, sent the requested files to documents (these had some content) and that is what I sent to you.

pavelk
Kubat Software
Kubat Software
Posts: 2445
Joined: Mon May 16, 2016 4:27 pm

Re: Info sent if pre-open crash?

Post by pavelk » Wed Feb 27, 2019 7:11 am

It seems like the problem you are experiencing is related to corrupt config file. Please go to C:\Users\XXX\AppData\Roaming\Kubat Software\Aggressors Ancient Rome\ where XXX is your Windows username and delete file "user.config". Before you delete it, please send it also via email so I can check why this happened.

Apart from that I recommend to update your GPU drivers. You have version 391.25 (it is already more than a year old) and current version is 419.17. You can find latest drivers here. Your GPU is GeForce GTX 1060 6GB.
Please send me that user.config file and let me know if that solved the problem.
Pavel

lordhoff
Corporal - Strongpoint
Corporal - Strongpoint
Posts: 66
Joined: Tue Aug 04, 2009 7:31 am

Re: Info sent if pre-open crash?

Post by lordhoff » Thu Feb 28, 2019 2:40 am

Interesting: the file was corrupted again. I know how to fix it now but it looks like I'll have to delete that file every time I open the game. It doesn't take but a minute so it's not a problem but I thought I should pass on this development.

pavelk
Kubat Software
Kubat Software
Posts: 2445
Joined: Mon May 16, 2016 4:27 pm

Re: Info sent if pre-open crash?

Post by pavelk » Thu Feb 28, 2019 8:10 am

lordhoff wrote:
Thu Feb 28, 2019 2:40 am
Interesting: the file was corrupted again. I know how to fix it now but it looks like I'll have to delete that file every time I open the game. It doesn't take but a minute so it's not a problem but I thought I should pass on this development.
hello again lordhoff,
it is even more interesting that you can reproduce that. I suspect that there is a problem with game's folders permissions. Can you please try to run this file? Windows might warn you that it can harm your computer but please trust me that it doesn't (it basically changes the permissions for folders created by the game where save and configuration files are located).
If it doesn't help, can you please change permissions for that folder (where user.config is located) manually? Here is how to do it (just instead of "Evan" add "Users").
Please let me know if that helped.
Pavel

lordhoff
Corporal - Strongpoint
Corporal - Strongpoint
Posts: 66
Joined: Tue Aug 04, 2009 7:31 am

Re: Info sent if pre-open crash?

Post by lordhoff » Thu Feb 28, 2019 9:01 pm

I had to turn off Malwarebytes to get it to run but, mission accomplished. I'll let you know if it worked.

EDIT: Opened without issue!

pavelk
Kubat Software
Kubat Software
Posts: 2445
Joined: Mon May 16, 2016 4:27 pm

Re: Info sent if pre-open crash?

Post by pavelk » Thu Feb 28, 2019 9:14 pm

lordhoff wrote:
Thu Feb 28, 2019 9:01 pm
I had to turn off Malwarebytes to get it to run but, mission accomplished. I'll let you know if it worked.

EDIT: Opened without issue!
So everything is running now? Great to hear that!

Post Reply

Return to “Aggressors: Tech Support”