Installation problems

Tech support for HISTORY™ Great Battles Medieval

Moderator: Slitherine Core

Post Reply
Tommy
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 1
Joined: Sat Dec 25, 2010 10:28 am

Installation problems

Post by Tommy » Sat Dec 25, 2010 10:31 am

hi.
each time i press the install button it starts loading extremly but nothing happens i just get "the game does'nt answer" and then if i try close it the install screen freeze and i have to restart comp but even then it wont work

pipfromslitherine
Site Admin
Site Admin
Posts: 8995
Joined: Wed Mar 23, 2005 10:35 pm

Post by pipfromslitherine » Sun Dec 26, 2010 6:50 am

Can you give us your system specs (the operating system, CPU, etc) and also the version of the game you have, and we will try and get you up and running as soon as possible.

Cheers

Pip

lionelppd138
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 1
Joined: Thu Jun 09, 2011 7:35 pm

Post by lionelppd138 » Thu Jun 09, 2011 7:39 pm

I have the same problem. I have windows 7, very good video card, plenty of ram. dvd/cd drive. Im able to run anything except for this game. Does is matter if im in the U.S. or not?

IainMcNeil
Site Admin
Site Admin
Posts: 13518
Joined: Fri Apr 01, 2005 10:19 am

Post by IainMcNeil » Fri Jun 10, 2011 9:31 am

Let us know which boxed version you have so we can try and track the problem. E.g. which country and which logo on the box?

Post Reply

Return to “HISTORY™ Great Battles Medieval : Tech Support”