Patching issues?

Tech support for PC & Mac. Please post your OS and version number when reporting bugs.

Moderators: Slitherine Core, NewRoSoft, FoG PC Moderator

DavidT
Staff Sergeant - StuG IIIF
Staff Sergeant - StuG IIIF
Posts: 268
Joined: Mon Jun 01, 2009 11:10 pm
Location: Northern Ireland

Updates

Post by DavidT » Sat Aug 14, 2010 11:31 am

I have just installed FoG on my PC along with the 1.2.8, 1.2.9 and 1.3.3 patches. Everything seems to have installed OK. However, when I load the game, it still reads version 1.1.2 in the bottom left corner of the screeen. Is this just a minor bug or have the patches not installed - and how do I tell?

leophoreo
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 1
Joined: Tue Mar 09, 2010 1:50 pm

Post by leophoreo » Sun Aug 15, 2010 8:38 am

I have applied 1.3.3 on top of 1.2.8 and when added immortal fire reverts to 1.01 and will only show rise of rome expansion pack unistalling and starting again has not helped. Any advice please. thanks

DavidT
Staff Sergeant - StuG IIIF
Staff Sergeant - StuG IIIF
Posts: 268
Joined: Mon Jun 01, 2009 11:10 pm
Location: Northern Ireland

Re: Updates

Post by DavidT » Sun Aug 15, 2010 10:49 am

DavidT wrote:I have just installed FoG on my PC along with the 1.2.8, 1.2.9 and 1.3.3 patches. Everything seems to have installed OK. However, when I load the game, it still reads version 1.1.2 in the bottom left corner of the screeen. Is this just a minor bug or have the patches not installed - and how do I tell?
Problem sorted.
I just downloaded 1.2.8 again and reinstalled it, followed by the other patches and it has now updated.

false_cause
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 2
Joined: Wed May 19, 2010 9:13 pm

Post by false_cause » Sun Aug 29, 2010 7:11 pm

Is there a link to download the mac version of the newest patches? I have 1.2.8 and the in-game updater does not work for me. I am using an iMac9,1

romainpek
Senior Corporal - Ju 87G
Senior Corporal - Ju 87G
Posts: 76
Joined: Thu Jun 10, 2010 8:12 pm

Post by romainpek » Sat Jan 01, 2011 6:18 pm

after 2 weeks vacations, I wanted to play my turn on a multiplayer battle.

My version is 1.4.0
The multiplayer screen refuses to launch and says I must update to the latest version: 1.4.2
So I press the automatic update button that proposes me to download 1.4.4 (?). I agree, it downloads 3 (?) patches and tels me it cannot erase FOG. exe...

I can't update my game !

The error message goes like this:

Detailed Information from the Updater:
1.4.0
2011-01-01 19:12:04 Downloading "files/fog/patch/win/FieldOfGlory/patch-1.4.0-1.4.2" to "f-1.4.0-1.4.2-4.part".
2011-01-01 19:12:37 File download received, HTTP status=200.
2011-01-01 19:12:37 Read 9109288 OK. (E=9109288, A=9109288)
2011-01-01 19:12:38 The downloaded file's signature is correct.
2011-01-01 19:12:38 Error while extracting file:Could not delete file E:\Program Files\Slitherine\Field of Glory\FieldOfGlory.exe
2011-01-01 19:12:38 Could not extract the file.
2011-01-01 19:12:50 Downloading "files/fog/patch/win/FieldOfGlory/patch-1.4.0-1.4.2" to "f-1.4.0-1.4.2-5.part".
2011-01-01 19:14:18 File download received, HTTP status=200.
2011-01-01 19:14:18 Read 9109288 OK. (E=9109288, A=9109288)
2011-01-01 19:14:19 The downloaded file's signature is correct.
2011-01-01 19:14:19 Error while extracting file:Could not delete file E:\Program Files\Slitherine\Field of Glory\FieldOfGlory.exe
2011-01-01 19:14:19 Could not extract the file.

Can you help?

keithmartinsmith
Field of Glory Moderator
Field of Glory Moderator
Posts: 1557
Joined: Mon Mar 30, 2009 1:26 pm

Post by keithmartinsmith » Sun Jan 02, 2011 9:37 am

If you are getting a message that it cannot erase FOG.exe then this is an issue with your users rights on that PC.

Are you an administrator on the PC?
Is it a home or work PC?
Did you say
yes
to any pop-up messages during the update.

Keith

romainpek
Senior Corporal - Ju 87G
Senior Corporal - Ju 87G
Posts: 76
Joined: Thu Jun 10, 2010 8:12 pm

Post by romainpek » Sun Jan 02, 2011 11:37 am

Thanks to your reply, I figured out this was probably due to a computer issue... I just rebooted and the patches were applied without difficulties.

Thanks !

JocaRamiro
Sergeant - 7.5 cm FK 16 nA
Sergeant - 7.5 cm FK 16 nA
Posts: 248
Joined: Sat Dec 05, 2009 10:19 pm

Post by JocaRamiro » Wed Feb 23, 2011 8:38 pm

It looks like this thread superceedes the issue I was trying to raise with regard to my problems moving ot a new system.

But, let me ask a question first.

If if deinstall FOG - to clear away all the debris of various updated attempts, and then, with my FOG license in hand, go and download patch 1.2.8, how do I then also get Rise of Rome, and Storm of Arrows back into the picture. Will it prompt me for the license IDs? Do I then go ahead and install the Immortal Fire and Swords and Scemiters files/patches I have?

I wonder if much of the trouble here is caused by the fact that new games are bundled in with patches to the basic system . What I would most like to do is to be able to download the latest FOG, and then sucessively reapply my permission to the other games/expansions.

Mead Walker aka JocaRamiro

IainMcNeil
Site Admin
Site Admin
Posts: 13519
Joined: Fri Apr 01, 2005 10:19 am

Post by IainMcNeil » Thu Feb 24, 2011 10:09 am

If you uninstall FoG it does not actually uninstall the army packs. You can reinstall FoG and your army packs shoudl work, assuming you have the latest version.

With the release of Legions Triumphant you will be able to add army packs without the installers, just the serial number. This should make it easier to stay up to date!

JocaRamiro
Sergeant - 7.5 cm FK 16 nA
Sergeant - 7.5 cm FK 16 nA
Posts: 248
Joined: Sat Dec 05, 2009 10:19 pm

Post by JocaRamiro » Tue Mar 01, 2011 5:41 pm

And now things do look pretty well.

To me, knowing that I needed to go all the way upgrading FOG and then should worry about the various army paks made it much easier.
Thanks for the help.

tofman04
Staff Sergeant - StuG IIIF
Staff Sergeant - StuG IIIF
Posts: 271
Joined: Tue Jan 06, 2009 6:13 am

Post by tofman04 » Fri Mar 11, 2011 7:51 am

maaza5417 wrote:OK, I have tried again this morning (Australian time), and still the same problem. I am running Windows Vista. I am running 1.2.9. There are no error messages, instead the download 100% completes, it then 100% validates and begins the install stage for between 2 and 5 seconds, and then reverts to downloading the patch again.
____________________________________
Warehouse Shelving
Pallet Racking
Hi,

If you are running fog 1.2.9 and you are using the in-game update, I think it tries to update to 1.5.1, last one, and in consequence there are more patches involved and are installed one after another.
Please look, when the download starts, and see if it is written in the window "Downloading Patch 1 from x" where x stands for a number.
If x > 1 then after the first is installed the updater starts the next patch in-line to download and install and so on.
Please be patient and look after messages which are written in the updater window.
When everything is finished you have in the updater window a "Done" button.

Cheers

sull51
Corporal - 5 cm Pak 38
Corporal - 5 cm Pak 38
Posts: 31
Joined: Mon Mar 08, 2010 4:29 am

Starting Over --- order of patching + addons

Post by sull51 » Thu Apr 21, 2011 2:23 am

My hard drive has given signs of dying and I want to transfer the game to another PC
I have the CD's for FOG and ROR
What is the correct order of installation for the CD's and patching.

Bermudadreieck
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 1
Joined: Sun Apr 11, 2010 3:35 pm

Post by Bermudadreieck » Thu Apr 28, 2011 10:28 am

Help wanted!
I have problems updating "Field of Glory" to Vers. 1.5.1

Following message appears
Game has stopped:
NullPointerException
1.5.0 2011-02-22
{}

Can you help?
Thanks a lot

Geordietaf
Staff Sergeant - Kavallerie
Staff Sergeant - Kavallerie
Posts: 306
Joined: Tue Feb 26, 2008 9:19 pm

Post by Geordietaf » Mon May 09, 2011 8:02 pm

I'm on Windows XP. Just updated through the ingame installer from 1.5.1 to 1.5.4. Big mistake. Game will not start now. Before I get to the launcher I get

'util.GameStoppedException
1.5.4 2011 05 05 win
{No CommonSettings}
{0}
uiplayer.htk.GraphicsArea.Paint o uiplayer.htk.GraphicsArea o uiplayer.gl.IGraphics
uiplayer.gl.DrawingArea.Event Render b o uiplayer.gl.DrawingArea
Delegate.IM Invoke
uiplayer.htk.RefreshThread.Event Run o uiplayer.htk.RefreshThread'

Now what?

spelk
Lance Corporal - SdKfz 222
Lance Corporal - SdKfz 222
Posts: 23
Joined: Thu Aug 13, 2009 7:57 pm
Location: UK
Contact:

Post by spelk » Sun Aug 14, 2011 7:20 pm

I've just tried to install my Field of Glory on my new laptop - But I installed v1.00 original, then updated with 1.28, and used the in game update to 1.60. Now I have every expansion, so I went through these in order, without any error messages showing up. But when I run the game, only the Rise of Rome expansion is available in the DAG. The other three show as Coming Soon. Also I go to multiplayer and it says its v1.10 and needs 1.60, however there is no link to Check for Updates in the menu any more. I run the update from an external link and it reports that the FoG is already up to date!

I don't know what to do, or in what order to install the game and then all expansions and then patch up. Help!!!

keithmartinsmith
Field of Glory Moderator
Field of Glory Moderator
Posts: 1557
Joined: Mon Mar 30, 2009 1:26 pm

Post by keithmartinsmith » Fri Aug 19, 2011 9:42 am

Hi, Looking at this issue and will get back shortly.

Keith

batesmotel
Field of Glory Moderator
Field of Glory Moderator
Posts: 3394
Joined: Thu Mar 13, 2008 8:52 pm

Post by batesmotel » Fri Aug 19, 2011 12:02 pm

If you re-install the original RoR update, it includes the 1.10 update which overwrites the others. You either need to install that right after the original FoG and then update to a version that supports on line update, or else just do the updates and then type in your registration numbers for the add ins you have without actually re-installing the add in downloads.

Chris
....where life is beautiful all the time

spelk
Lance Corporal - SdKfz 222
Lance Corporal - SdKfz 222
Posts: 23
Joined: Thu Aug 13, 2009 7:57 pm
Location: UK
Contact:

Post by spelk » Fri Aug 19, 2011 12:34 pm

I think I patched to 1.60, then installed some of the expansions, and they somehow took my version back to v1.1.0, yet the main game still thinks its at 1.60. Weird stuff.

I've started again, and am installing the global catch up 1.2.8 patch, then will have to patch online to 1.60 and just register the serials for my expansions, instead of trying to run the installers.

...

Well it seems installing v1.28 over my broken v1.60/v1.1.0 combo, and then patching through the in-game check for updates, has fixed it.

All the relevant expansions are now available, and I didn't have to enter any codes. But perhaps that was a result of me installing the lower version expansions separately. I'd initially thought Slitherine were doing something clever by detecting what expansions I'd bought, but I hadn't entered my Slitherine login for my multiplayer account by then - so that couldn't have been the case.

All in all though, it is a very confusing process, not helped by the update mechanism changing half way through and going in-game. I find the splash screen telling me theres an update available annoying because when you click on the link, it takes you to a forum post, with details of whats in the update, but with no link to the actual update. I guess its just an info link, but you then have to go in-game to make the update itself.

I suspect the correct way to do this, if anyone else has to re-install their Field of Glory is to

Install from the original release Field of Glory v1.0.0
Then download the v1.28 patch - which takes any version of FoG up to v1.28
Then update using the in-game "Check for Updates" to patch up to the latest version.
Then register any expansions/codes with the game.

From then on, always use the in-game update mechanism.

Not sure how far Matrix and Slitherine are on the road to coalescing but some information needs to be imparted on the main buy/download page to make sure existing users know the correct order/procedure to install the game and patch it up accordingly.

I'm not even sure if you purchased the Slitherine version, can you gain access to the official Matrix one free-of-charge?

EricS
Sergeant - Panzer IIC
Sergeant - Panzer IIC
Posts: 194
Joined: Thu Aug 27, 2009 8:35 am

Post by EricS » Fri Aug 19, 2011 1:29 pm

Please try to use any manually-downloadable patch that takes you to 1.4.0 or newer in one go. You should then see the 'Check for Updates' button in the main menu, and be able to get to the latest version.

keithmartinsmith
Field of Glory Moderator
Field of Glory Moderator
Posts: 1557
Joined: Mon Mar 30, 2009 1:26 pm

Post by keithmartinsmith » Fri Aug 19, 2011 4:08 pm

If you have any earlier version installed just installing the 160 patch from here

http://www.matrixgames.com/products/378/downloads/

Should fix all issues.

If any serial numbers are not working you can re-enter them via the serial option on the initial menu.

Keith

Post Reply

Return to “Field of Glory : Tech Support”