Editor not starting

Tech support for Panzer Corps

Moderators: Slitherine Core, Panzer Corps Moderators, Panzer Corps Design

Post Reply
captainjack
Colonel - Fallschirmjäger
Colonel - Fallschirmjäger
Posts: 1472
Joined: Thu Sep 13, 2012 7:42 am

Editor not starting

Post by captainjack » Sat Dec 01, 2018 10:49 pm

I tried opening the editor yesterday. It displayed a blank map (with about 12 x 12 hex grid visible and no terrain) and a list of units to the side.
It then paused for about 10 seconds and closed itself, leaving only the Panzer Corps start screen.

I tried restarting the PC, copying over the editor files from a backup copy, starting the editor directly from inside the folder, but have the same result each time. It has previously worked on this machine.

I'm hoping there's something I can do that doesn't involve a full reinstall as the last one took a long time about four hours, spread over most of a day).

dalfrede
Sergeant - 7.5 cm FK 16 nA
Sergeant - 7.5 cm FK 16 nA
Posts: 211
Joined: Wed Mar 15, 2017 7:48 pm

Re: Editor not starting

Post by dalfrede » Sun Dec 02, 2018 3:10 am

Start with your equip file, if it is screwed up the editor may not work.
Place your original 'default' equip file the data folder to see if it then works.

captainjack
Colonel - Fallschirmjäger
Colonel - Fallschirmjäger
Posts: 1472
Joined: Thu Sep 13, 2012 7:42 am

Re: Editor not starting

Post by captainjack » Mon Dec 03, 2018 6:04 am

Thanks for the suggestion dalfrede. Unfortunately it didn't work.

I have a growing suspicion that I'm in for yet another reinstall.

dalfrede
Sergeant - 7.5 cm FK 16 nA
Sergeant - 7.5 cm FK 16 nA
Posts: 211
Joined: Wed Mar 15, 2017 7:48 pm

Re: Editor not starting

Post by dalfrede » Mon Dec 03, 2018 6:17 pm

captainjack wrote:
Sat Dec 01, 2018 10:49 pm
I tried opening the editor yesterday. It displayed a blank map (with about 12 x 12 hex grid visible and no terrain) and a list of units to the side.
It then paused for about 10 seconds and closed itself, leaving only the Panzer Corps start screen.
The blank map is the default new map.
It appears that the editor is starting up correctly, but when it tries to load the scenario it crashes.

I renamed my Equip file, and the editor spends it wheels for a few seconds and never comes up.
I am running under wineskin and I can tell when it is spinning it's wheels and when it has crashed.

Try to rename your new scenario folder, I suspect that your 'map' is corrupt.
~/mygames/PanzerCorp/Mods/MyNewScenario

The editor automatically loads the last scenario that it edited, so if it is corrupted the editor can't be used.
There should be a file somewhere that can be edited but I don't know which one.

With the Mac if you rip a CD in iTunes and move the folder, the OS keeps track of the folder and iTunes can find the moved folder. But if you rename the folder it loses track. I don't know how it works on the PC.

captainjack
Colonel - Fallschirmjäger
Colonel - Fallschirmjäger
Posts: 1472
Joined: Thu Sep 13, 2012 7:42 am

Re: Editor not starting

Post by captainjack » Thu Dec 06, 2018 1:13 am

Thanks dalfrede. I've tried different equipment files and it hasn't helped yet.
I think you are right about the editor using a corrupt template, as the main game runs OK. Unless I can identify the specific file that the editor uses I suspect a reinstall is needed. I'm off for a short while very soon, but will try out your idea more fully when I get back.

Post Reply

Return to “Panzer Corps : Tech Support”