Slitherine Launcher Technical Support Issue

Moderator: Slitherine Core

Tomn
Lance Corporal - Panzer IA
Lance Corporal - Panzer IA
Posts: 16
Joined: Thu Apr 02, 2015 1:54 pm

Re: Slitherine Launcher Technical Support Issue

Post by Tomn » Fri Apr 03, 2020 7:05 pm

Well, reinstalling IE did in fact resolve whatever issue was causing the slowdown while browsing, but unfortunately it doesn't seem to have done anything for the launcher. I've tried running the launcher for a space of up to five minutes before to see if it'd resolve itself with no effects, which I thought was fair, but I can try a longer test - though I'd not be terribly happy about a load time of, say, fifteen minutes per game. Would make importing and explorting Field of Glory: Empires battles to Field of Glory 2 a gigantic crick in the neck.

Appreciate your continued assistance in what I'll admit is a rather peculiar issue.

Edit: After waiting nearly half an hour for the FoG2 launcher to resolve I think I feel comfortable in saying that even if waiting longer would let the launcher unfugger itself, it'd not be worth it.

VPaulus
Slitherine
Slitherine
Posts: 8070
Joined: Mon Dec 27, 2010 8:33 pm
Location: Portugal

Re: Slitherine Launcher Technical Support Issue

Post by VPaulus » Mon Apr 06, 2020 9:24 am

Please try to disable all background programs in case these are interfering with the normal running of the game.
You can do this by running msconfig and disabling all non-windows start-up programs and services (except Steam).
Then once you have disabled all non-Microsoft services (except the Steam ones), please run the game and see if the issue persists.
If it does not, please then reopen msconfig and reenable those services, one by one, until you find the program causing the problem.
A tutorial on how to do this can be found below:
https://eu.battle.net/support/en/article/23848

Tomn
Lance Corporal - Panzer IA
Lance Corporal - Panzer IA
Posts: 16
Joined: Thu Apr 02, 2015 1:54 pm

Re: Slitherine Launcher Technical Support Issue

Post by Tomn » Tue Apr 07, 2020 2:31 am

Afraid it's still a no-go. Background programs would not appear to be the issue.

pipfromslitherine
Site Admin
Site Admin
Posts: 9151
Joined: Wed Mar 23, 2005 10:35 pm

Re: Slitherine Launcher Technical Support Issue

Post by pipfromslitherine » Tue Apr 07, 2020 3:19 pm

Try blocking the launcher in Windows firewall. It may behave better if it cannot connect to the internet at all.

Cheers

Pip
follow me on Twitter here

Tomn
Lance Corporal - Panzer IA
Lance Corporal - Panzer IA
Posts: 16
Joined: Thu Apr 02, 2015 1:54 pm

Re: Slitherine Launcher Technical Support Issue

Post by Tomn » Wed Apr 08, 2020 3:46 am

Hmm. Not sure what the launcher is listed as on the firewall, but I will say that blocking the games themselves (Field of Glory 2's autorun, for instance) doesn't seem to have an effect. Is that blocking the launcher themselves, or does it have a different name there?

VPaulus
Slitherine
Slitherine
Posts: 8070
Joined: Mon Dec 27, 2010 8:33 pm
Location: Portugal

Re: Slitherine Launcher Technical Support Issue

Post by VPaulus » Wed Apr 08, 2020 9:18 am

The launcher for Field of Glory 2 is "autorun.exe".

Tomn
Lance Corporal - Panzer IA
Lance Corporal - Panzer IA
Posts: 16
Joined: Thu Apr 02, 2015 1:54 pm

Re: Slitherine Launcher Technical Support Issue

Post by Tomn » Wed Apr 08, 2020 12:06 pm

Yeah, in that case that didn't work - like I said earlier, I tried blocking the autorun to no effect.

pipfromslitherine
Site Admin
Site Admin
Posts: 9151
Joined: Wed Mar 23, 2005 10:35 pm

Re: Slitherine Launcher Technical Support Issue

Post by pipfromslitherine » Wed Apr 08, 2020 3:12 pm

What happens if you run the launcher (which will hang) and then manually try and run the game EXE itself?

Cheers

Pip
follow me on Twitter here

Tomn
Lance Corporal - Panzer IA
Lance Corporal - Panzer IA
Posts: 16
Joined: Thu Apr 02, 2015 1:54 pm

Re: Slitherine Launcher Technical Support Issue

Post by Tomn » Wed Apr 08, 2020 5:43 pm

Looks like different games have different results.

Field of Glory 2 ends up in two separate instances of the launcher running and hanging.

Field of Glory: Empires' EXE has always started the game fine without issues.

DC: Barbarossa runs the game but then pops up an error message saying that the game was not launched from Steam and will now close down. (On checking it does this if you run the main EXE without going through the launcher anyways.)

Sengoku Jidai also does the two hanging launchers dance.

Warhammer Gladius does a weird thing where it tries to update the game via Steam and then fails to run (though that's probably because I've set it up to run one of the legacy versions instead of the latest version)

That's all I got installed at the moment.

pipfromslitherine
Site Admin
Site Admin
Posts: 9151
Joined: Wed Mar 23, 2005 10:35 pm

Re: Slitherine Launcher Technical Support Issue

Post by pipfromslitherine » Wed Apr 08, 2020 7:41 pm

I am pretty much out of ideas. I am pretty sure (given you say that you don't have any third party AVs or firewalls installed) that somehow your older IE files have gotten corrupted (the improvements you saw by reinstalling point that direction, but obviously the repair didn't solve whichever issue this is). You could try running the Windows system file checker (open an Admin command line and enter

sfc /scannow

This will do a check on all the system files.

Otherwise you might be best just trying for a refund from Steam and then buying the games directly from us. Even if the launcher still has issues I know that the EXEs can be run directly.

Cheers

Pip
follow me on Twitter here

Tomn
Lance Corporal - Panzer IA
Lance Corporal - Panzer IA
Posts: 16
Joined: Thu Apr 02, 2015 1:54 pm

Re: Slitherine Launcher Technical Support Issue

Post by Tomn » Thu Apr 09, 2020 5:25 am

Running the scannow noted that "Windows Resource Protection found corrupt files but was unable to fix some of them." I've attached the CBS log for details. Trying out the launcher showed that whatever the scan fixed, it wasn't what was necessary to solve the issue. Really hope this leads to a solution. because I sincerely doubt Steam will offer refunds on games I've owned and played for months/years and I do not fancy buying the game twice.
Attachments
CBS.rar
(112.6 KiB) Downloaded 4 times

pipfromslitherine
Site Admin
Site Admin
Posts: 9151
Joined: Wed Mar 23, 2005 10:35 pm

Re: Slitherine Launcher Technical Support Issue

Post by pipfromslitherine » Thu Apr 09, 2020 3:45 pm

This gives more detailed instructions on how to try and repair system files:

https://support.microsoft.com/en-ca/hel ... ted-system

At least we know that the issue is that something got corrupted and is impacting the launcher plugin.

Cheers

Pip
follow me on Twitter here

Tomn
Lance Corporal - Panzer IA
Lance Corporal - Panzer IA
Posts: 16
Joined: Thu Apr 02, 2015 1:54 pm

Re: Slitherine Launcher Technical Support Issue

Post by Tomn » Fri Apr 10, 2020 6:29 am

Hey, that did it! It turns out that running "DISM.exe /Online /Cleanup-image /Restorehealth" BEFORE running "sfc /scannow" allows the system to automatically repair the corrupted files. Not sure if this is helpful or not, but looking at the logs here's the files that needed fixing and got fixed:

2020-04-10 14:06:01, Info CSI 000003cd [SR] Repairing corrupted file \??\C:\WINDOWS\SysWOW64\\d3d10warp.dll from store
2020-04-10 14:06:22, Info CSI 000003cf [SR] Repairing corrupted file \??\C:\WINDOWS\SysWOW64\\MFMediaEngine.dll from store
2020-04-10 14:06:22, Info CSI 000003d2 [SR] Repairing corrupted file \??\C:\WINDOWS\System32\WindowsPowerShell\v1.0\en-US\\powershell.exe.mui from store

Again, thanks for your patience and persistence in this!

pipfromslitherine
Site Admin
Site Admin
Posts: 9151
Joined: Wed Mar 23, 2005 10:35 pm

Re: Slitherine Launcher Technical Support Issue

Post by pipfromslitherine » Fri Apr 10, 2020 2:50 pm

Woot! Glad we managed to get you up and running. Thank you for your patience.

Cheers

Pip
follow me on Twitter here

mysticbanshee
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 1
Joined: Mon Apr 20, 2020 5:33 pm

Re: Slitherine Launcher Technical Support Issue

Post by mysticbanshee » Sat Apr 25, 2020 5:28 pm

I've tried running the launcher for a space of up to five minutes before to see if it'd resolve itself with no effects, which I thought was fair, but I can try a longer test - though I'd not be terribly happy about a load time of, say, fifteen minutes per minecraft auto clicker game.
Last edited by mysticbanshee on Wed Apr 29, 2020 3:40 am, edited 1 time in total.

pipfromslitherine
Site Admin
Site Admin
Posts: 9151
Joined: Wed Mar 23, 2005 10:35 pm

Re: Slitherine Launcher Technical Support Issue

Post by pipfromslitherine » Mon Apr 27, 2020 3:04 pm

Are you having a similar issue to the original poster?

Cheers

Pip
follow me on Twitter here

Post Reply

Return to “General Discussion”