The shipping address you used is wrong!!!

Having problems with the download service? Need help ordering from the Slitherine shop? Tell us your problems and we'll do what we can to help!

Moderator: Slitherine Core

Post Reply
jassiey
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 2
Joined: Sat Nov 16, 2019 10:41 pm

The shipping address you used is wrong!!!

Post by jassiey » Fri Nov 22, 2019 6:03 pm

Hello, The shipping address is incorrect. The second line of street address
is missing!!!!!

It should be:
*edited to remove personal info*

I wrote you 2 days ago but no one replies.



On Wed, Nov 20, 2019 at 10:47 AM Slitherine Fulfilment Service <
fulfilment@slitherine.co.uk> wrote:

> Dear NanZheng,
>
>
> Good news! Your order XXXXX has been shipped!
>
> The order is for following items:
>
> 1. Command: Modern Operations
> 1. Command: Modern Operations
>
>
> Your delivery address is:
>Edited to remove personal info
>
> Your order has been dispatched using the Royal Mail Parcel Service.
>
> Depending on your location here is your estimated delivery time:
> UK mainland - 2-4 working days
> Rest of Europe - 3-8 working days
> US & Rest of the World 5-20 working days
>
> In some rare cases orders may take as much as 21 days to arrive. If you
> have not received your order within 21 working days please get in touch.
>
> If you have any problems or concerns please contact the team at
> support@slitherine.co.uk.
>
>
> Best regards,
>
> The Slitherine Fulfilment Service

pipfromslitherine
Site Admin
Site Admin
Posts: 9253
Joined: Wed Mar 23, 2005 10:35 pm

Re: The shipping address you used is wrong!!!

Post by pipfromslitherine » Fri Nov 22, 2019 6:52 pm

Did you contact support@slitherine.co.uk? Please check your spam folder in case the reply was put there. I will ensure that support also looks at this thread.

Cheers

Pip
follow me on Twitter here

JosephM
Slitherine
Slitherine
Posts: 240
Joined: Tue Mar 18, 2014 10:17 am

Re: The shipping address you used is wrong!!!

Post by JosephM » Mon Nov 25, 2019 12:46 pm

Hello Jassiey,

I have been replying to your emails but in case these still aren't received I thought it best to reply to this thread. I have also edited your thread to remove your personal information and the order number.

But we did get your earlier emails and asked the production team to confirm this. They have shipped this to the correct address, and unfortunately there is a bug within the automatic replies from our shipment system where this is nor showing the 2nd line of the shipping address, but we should have sent this to the correct address regardless. Sorry for the confusion and that the earlier emails were not received, but this should all be fixed for you

jassiey
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 2
Joined: Sat Nov 16, 2019 10:41 pm

Re: The shipping address you used is wrong!!!

Post by jassiey » Tue Nov 26, 2019 3:23 pm

I received your reply yesterday

Thank you.

Post Reply

Return to “Online Ordering & Support”