Poll: GS v3.0 status for users

PSP/DS/PC/MAC : WWII turn based grand strategy game

Moderators: firepowerjohan, rkr1958, Happycat, Slitherine Core

GS v3.0 status for users

1. GS v3.0 works (Matrixgames version with serial)
14
30%
2. GS v3.0 works (Slitherine version with serial)
13
28%
3. GS v3.0 works (Slitherine version without serial)
0
No votes
4. GS v3.0 works (MAC version with serial)
10
21%
5. GS v3.0 does not work (Matrixgames version with serial)
1
2%
6. GS v3.0 does not work (Slitherine version with serial)
8
17%
7. GS v3.0 does not work (Slitherine version without serial)
1
2%
8. GS v3.0 does not work (MAC version with serial)
0
No votes
 
Total votes: 47

Rasputitsa
Administrative Corporal - SdKfz 251/1
Administrative Corporal - SdKfz  251/1
Posts: 125
Joined: Wed Apr 15, 2009 10:58 am

Re: Poll: GS v3.0 status for users

Post by Rasputitsa » Tue Sep 24, 2013 8:52 am

Matrix (Patches Scrolls) 3.0 update worked when applied to a vanilla v1.0 copy, that had been updated to v 1.12. It did not work when applied to v1.0, without previous updates.

Peter Stauffenberg
General - Carrier
General - Carrier
Posts: 4706
Joined: Sun Jul 08, 2007 4:13 pm
Location: Oslo, Norway

Re: Poll: GS v3.0 status for users

Post by Peter Stauffenberg » Tue Sep 24, 2013 2:19 pm

richardsd wrote:
Blathergut wrote:Is there a reason it is not a full install? Some sort of note about where to install would have been a great help and saved an evening of frustration.
it has bugs :D
No it doesn't. It works the same way as the update version. The main reason it's not available yet is that it has to replace the current full version and linked to the purchase system for Matrix games / Slitherine. That is more work than just posting a link to an update.

Peter Stauffenberg
General - Carrier
General - Carrier
Posts: 4706
Joined: Sun Jul 08, 2007 4:13 pm
Location: Oslo, Norway

Re: Poll: GS v3.0 status for users

Post by Peter Stauffenberg » Tue Sep 24, 2013 2:22 pm

Rasputitsa wrote:Matrix (Patches Scrolls) 3.0 update worked when applied to a vanilla v1.0 copy, that had been updated to v 1.12. It did not work when applied to v1.0, without previous updates.
True. You need CEAW v1.12 to play GS v3.0. All new versions of CEAW are v1.12. So older versions than that means you have a very old version originally.

This is one problem we have had with testing the GS v3.0 installer. There are so many different versions of the vanilla game version out.

What we do know works with GS v3.0 is the following.

CEAW v1.12 with a serial number.

DanSlayer
Lance Corporal - SdKfz 222
Lance Corporal - SdKfz 222
Posts: 26
Joined: Tue Nov 06, 2012 10:55 am
Location: Berlin, Germany

Re: Poll: GS v3.0 status for users

Post by DanSlayer » Wed Sep 25, 2013 10:15 pm

GS v3.0 works by installation to Matrixgames version with serial perfectly. Only the desktop shortcut lost the icon parameters, so I rebuild them manually. v3.0 works - THANK YOU GUYS! :mrgreen:

...but the german translation is not the best - can I help you probably to "refine" the ger language? 8)
Anyone, who has ever looked into the glazed eyes of a soldier dying on the battlefield, will think hard before starting a war.

Otto von Bismarck

_Augustus_
Sergeant - 7.5 cm FK 16 nA
Sergeant - 7.5 cm FK 16 nA
Posts: 213
Joined: Mon Dec 28, 2009 6:36 pm

Re: Poll: GS v3.0 status for users

Post by _Augustus_ » Thu Sep 26, 2013 4:53 pm

Greetings,

I've a GEaW Gold purchased from Slitherine in Jan '10 with a serial number.

Patches Scrolls download from Matrix Games site stops after asking a serial number. "Invalid serial number" pop ups as the reason :x

A.

laramieela
Administrative Corporal - SdKfz 251/1
Administrative Corporal - SdKfz  251/1
Posts: 133
Joined: Thu Jun 09, 2011 4:24 am

Re: Poll: GS v3.0 status for users

Post by laramieela » Fri Sep 27, 2013 3:25 am

I was worried, reading the forum, but all went very well.

Peter Stauffenberg
General - Carrier
General - Carrier
Posts: 4706
Joined: Sun Jul 08, 2007 4:13 pm
Location: Oslo, Norway

Re: Poll: GS v3.0 status for users

Post by Peter Stauffenberg » Fri Sep 27, 2013 11:15 am

_Augustus_ wrote:Greetings,

I've a GEaW Gold purchased from Slitherine in Jan '10 with a serial number.

Patches Scrolls download from Matrix Games site stops after asking a serial number. "Invalid serial number" pop ups as the reason :x

A.
Is the serial number a 16 digit number. Try typing it with - between every 4 digits.

If that doens't work you need to contact Slitherine about this issue. Give them the serial number you have so they can verify if it's a legal one.

_Augustus_
Sergeant - 7.5 cm FK 16 nA
Sergeant - 7.5 cm FK 16 nA
Posts: 213
Joined: Mon Dec 28, 2009 6:36 pm

Re: Poll: GS v3.0 status for users

Post by _Augustus_ » Fri Sep 27, 2013 12:40 pm

Hi S.berg,

Yes, I tried entering the serial number by typing with and without the "-"s and by copypasting taking care that there are no spaces pasted before or after the number. I guess I need to contact Slitherine then. Thanks.

A.

supermax
Lieutenant Colonel - Panther D
Lieutenant Colonel - Panther D
Posts: 1286
Joined: Sat Dec 29, 2007 7:05 pm

Re: Poll: GS v3.0 status for users

Post by supermax » Sat Sep 28, 2013 2:40 pm

all good for me. Installed it and it worked like a charm

Peter Stauffenberg
General - Carrier
General - Carrier
Posts: 4706
Joined: Sun Jul 08, 2007 4:13 pm
Location: Oslo, Norway

Re: Poll: GS v3.0 status for users

Post by Peter Stauffenberg » Sat Sep 28, 2013 3:26 pm

According to the polls only about 12-13% of the existing players have problems getting the installer to work. I suggest those who can't make the game work to contact Slitherine to get a verification that their serial number is valid.

_Augustus_
Sergeant - 7.5 cm FK 16 nA
Sergeant - 7.5 cm FK 16 nA
Posts: 213
Joined: Mon Dec 28, 2009 6:36 pm

Re: Poll: GS v3.0 status for users

Post by _Augustus_ » Sat Sep 28, 2013 4:21 pm

All the buzz here on the forum for the GS 3.0 release mentioned Matrix Games website as a source for the update. That's where I got the update installer that didn't accept my serial number on Thursday. The installer I downloaded today from the Slitherine web site accepted my serial number and updated the GS smoothly.

I mention this just in case someone else has the same trouble with the serial number.

A.

hags99
Corporal - 5 cm Pak 38
Corporal - 5 cm Pak 38
Posts: 33
Joined: Wed Mar 09, 2011 9:24 pm
Location: Miami, Florida USA

Re: Poll: GS v3.0 status for users

Post by hags99 » Thu Oct 03, 2013 1:32 am

GS v3.0 does not work. Followed instructions on Slitherine site for PC version. Uninstalled GS v2.0. Downloaded GS v3.0. Installed to CEAW folder. Now I get the game launcher flash 'n crash. Vanilla CEAW (1.12) won't run now either. Serial number (Matrix version) worked fine however.
What do?
***** update *********************
Cleaned everything off and re-installed CEAW, 1.12 patch, and GS 3.0 in the same folder and got the game to run.
However........ selected low-resolution from the option selection screen, so the game graphics are awful, and now the graphics selection screen does not appear
on start-up, so I can't change the graphics quality! Does anyone know where this option is stored, or how to get the graphics selection screen to appear?
ALSO, the zoom does not zoom to max close-up like in GS 2.0. This makes it hard to identify the units. Is this a bug or a feature of GS3.0?
Over-all, GS3.0 is much harder get running than GS2.0 and lacks graphics quality. If I can't resolve these issues I'm ready to fall back to GS2.0 which
was an awesome product.
So pls HELP!
Last edited by hags99 on Thu Oct 03, 2013 8:26 pm, edited 1 time in total.

chenxiang
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 3
Joined: Thu Oct 03, 2013 9:02 am

Re: Poll: GS v3.0 status for users

Post by chenxiang » Thu Oct 03, 2013 9:16 am

It found my serial without asking and the game has continued to run swimmingly since the update.

Peter Stauffenberg
General - Carrier
General - Carrier
Posts: 4706
Joined: Sun Jul 08, 2007 4:13 pm
Location: Oslo, Norway

Re: Poll: GS v3.0 status for users

Post by Peter Stauffenberg » Fri Oct 04, 2013 9:45 am

hags99 wrote:However........ selected low-resolution from the option selection screen, so the game graphics are awful, and now the graphics selection screen does not appear
on start-up, so I can't change the graphics quality! Does anyone know where this option is stored, or how to get the graphics selection screen to appear?
ALSO, the zoom does not zoom to max close-up like in GS 2.0. This makes it hard to identify the units. Is this a bug or a feature of GS3.0?
Over-all, GS3.0 is much harder get running than GS2.0 and lacks graphics quality. If I can't resolve these issues I'm ready to fall back to GS2.0 which
was an awesome product.
So pls HELP!
You need to go into
C:\Users\My documents\<userid>\My documents\CEAW Grand Stategy 3.00

You can either edit or delete the file there called GS300_settings.txt. If you delete the file you force the game to go through initial setup where you can select the language, resolution etc.

Change the value in the file from LOW_RAM 1 to LOW_RAM 2
Then high resolution is enabled

You said: Over-all, GS3.0 is much harder get running than GS2.0 and lacks graphics quality

I think it's strange that you make the conclusion that GS v3.0 lacks graphics quality when you select low resolution during the installation. Then zoom level 3 is disabled. If you select high resolution (LOW_RAM 2) then you have zoom level 3 too. There is NO graphical change in quality between the vanilla game, GS v2.0 and GS v3.0. The functionality to select high and low resolution is part of the vanilla game. You would have seen exactly the same in GS v2.0 or the vanilla game.

I think you don't remember all the installation issues we had with GS v2.0. The truth is that GS v3.0 is actually much easier to install than GS v2.0. We had a lot more support issues with users not having success with the installation on GS v2.0. That is the main reason we no longer support very old Slitherine versions without serial number. Maybe YOU got problem with GS v3.0, but most users actually installed GS v3.0 without a glitch. Some of the issues we had was that Matrixgames released their initial version that didn't support Slitherine serial numbers. Usually it's a good idea to download a new version from the same site as where you purchased the original version. I can understand people being impatient and went for the Matrixgames version when they had the Slitherine version since GS v3.0 was released first on the Matrixgames site.

hags99
Corporal - 5 cm Pak 38
Corporal - 5 cm Pak 38
Posts: 33
Joined: Wed Mar 09, 2011 9:24 pm
Location: Miami, Florida USA

Re: Poll: GS v3.0 status for users

Post by hags99 » Fri Oct 04, 2013 1:45 pm

Thank you very much. It s working fine now that I changed the value to LOW_RAM 2. I was messing with the wrong GS300_settings.txt file. There are 2 of them! One in the game installation folder, and one in My documents. Now everything works fine. This is one of my all-time favorites, been playing it off-and-on for years. Sorry to be a pain, thanks again!

Peter Stauffenberg
General - Carrier
General - Carrier
Posts: 4706
Joined: Sun Jul 08, 2007 4:13 pm
Location: Oslo, Norway

Re: Poll: GS v3.0 status for users

Post by Peter Stauffenberg » Fri Oct 04, 2013 8:51 pm

The one in the game folder is the source file used to copy into the file in the my documents folder. So if you delete the my documents file then the one from the game file will be copied again.

Eggmanrc
Lance Corporal - SdKfz 222
Lance Corporal - SdKfz 222
Posts: 24
Joined: Fri Nov 12, 2010 11:25 pm

Re: Poll: GS v3.0 status for users

Post by Eggmanrc » Mon Oct 07, 2013 7:12 am

Installed 3.0 with previous version being 2.1. I had to copy the jre directory to move past the DOS "flash" screen. Game ran fine after that except......

I have no sound. I clicked enable sound at launch. Clicked Sound Effects and Music at options screen. After still not having sound, I checked the GS300_settings.txt file and saw NO_SOUND_Effects and NO_MUSIC were set to 1. Changed these to 0, saved, and relaunched game. Still no sound.

Any ideas? I didn't have this with 2.10 so I doubt it's hardware or driver related. I don't want to start randomly copying sound files without hearing of others that have had and fixed this one. A big thank you VERY much for those that spent time on 3.0, both Slitherine and others. From the comments, looks like I may be spending a few evenings enjoying the new toys.

Agathos2288
Private First Class - Wehrmacht Inf
Private First Class - Wehrmacht Inf
Posts: 8
Joined: Thu Sep 05, 2013 1:16 am

Re: Poll: GS v3.0 status for users

Post by Agathos2288 » Mon Oct 07, 2013 5:03 pm

Okay, I'm new to CEaW--so, I may have had a few newbie issues w/ this install. So, if you're new, this may help.

After a clean install of the original Gold Edition, followed by saying yes to installation of GS 2.0 (Grand Strategy 2.0 that came w/ the initial purchase download), I downloaded the GS 3.0 from the Slitherine page following the link.

At this point, I launched the 3.0 install from the 'downloads' folder. It asked for my serial number again and then proceeded to ask for an install folder. The great confusion for me at this point is that the directory it says it's going to use is blank. Perhaps I should have just accepted and moved on. But, what worked for me was selecting the 'Grand Strategy Mods' folder from my original install. The install proceeded as normal and completed. I then was able to launch the game, and can confirm it's 3.0 from the lower right corner of the opening game screen. I did have the sound issue mentioned in this forum, but bringing up the options menu revealed that the default for sound effects and music was set to off. I changed this, and it all works fine!

I think the greatest confusion is the blank path listed for the opening install of 3.0.

Hope this helps!

Post Reply

Return to “MILITARY HISTORY™ Commander - Europe at War : General Discussion”