Page 1 of 1

Commander EAW Grand Strategy V4 Issues

Posted: Fri Sep 13, 2019 6:19 am
by VeganTed
Apologies in advance if this is not the right place to raise this - or if my query has been dealt with elsewhere. To be honest, I find this website a bit of a navigational nightmare and am unsure of how best to use it! My previous problem was dealt with directly via email from Slitherine Support, but they are unable to answer this query so advised me instead to raise it in a forum. Here goes (deep breath!)...

I have been playing (always as the Axis versus the AI) V3.10 successfully (other than frequent crashing) for a couple of years now. I tried to play V4.0 about a year ago (as the Axis) but gave up after Gneisnau did a 'Philadelphia Experiment' on me by disappearing early in the game off the north-west coast of Scotland before reappearing several turns later! The game then went on to hang before I quit. There are a few issues that I experience with V3.10, such as US ownership of transport loops not relinquishing after USA has surrendered, and the depth-charge/mine facility(?) of vessels always returning "No Contact", plus spurious informational messages appearing after USA is conquered, but generally these do not spoil the game.

However, recently I tried to play V4.0 again (as the Axis) and experienced the following issues: After DoW on Russia in June 1941, the AI turn takes a full five minutes to complete per turn, with mostly nothing happening during this time. This gradually diminishes a little as one gets nearer to total occupation of USSR but is still excessive and fun-sapping. Still, I persevered with the game until turn 72 (July 22 1943) when suddenly - after Egypt having long fallen to the Italians and Afrika Korps, and subsequently Iraq, Persia and the Caucasus following suit - Australian and New Zealand forces (plus HMS Malaya) mysteriously reappeared between Suez and Cairo and recaptured Suez! (Cairo had been garrisoned but Suez had not.) Now, not having previously reached this far in the V4.0 game, I considered that this might be a plausible outcome, if Churchill had somehow managed to sneak reinforcements up from the Red Sea - if it hadn't been for the following shock: there were TWO copies each of 2nd New Zealand corps and 9th Australian corps, as well as TWO Malayas! On subsequent turns, as fast as I destroyed the NZ and Oz forces, they reappeared in the same place on the following turn - like the animals in the ark: two by two! Plus, an additional two new Malayas appeared each turn until there were EIGHT of them crammed into the Red Sea below the canal!

As well as the reappearance of the Egyptian forces and HMS Malayas, each turn saw the re-emergence of the old informational messages both at the start and at the end of every AI turn: "Iraq surrenders to Italy" and Egypt surrenders to Italy", along with "Egypt joins the Allies", Iraq joins the Allies" and the message about the ME rail network and Churchill reinforcements to Suez.

I assume that some sort of programming loop has been triggered - I don't know. What I can say for sure is that it makes the game unplayable - which is pretty annoying after having spent the best part of two days getting to that point!

It looks to me like there is a version 4.029 available - if so, I am unable to find much mention of it and certainly no update files. Oh, and the Check for Update option on the V4 menu always fails with "Unable to determine the installed version. Could not get the specified value's data."

Please advise me on what I should do, if my issues have been seen by others, and how to upgrade to a bug-free version of either version, 3 or 4. Thank you.

I am playing on a Sony Vaio laptop with Windows 7 OS and 6GB RAM.

Any help, advice or guidance would be greatly appreciated; thank you.

Andy Terry

Re: Commander EAW Grand Strategy V4 Issues

Posted: Sat Sep 14, 2019 2:06 am
by GeneralButtercup82
That is a glitch that was introduced late the modification process and it is irritating. When playing a human opponent I make a deal that all the ships will be transferred to the western south Atlantic and have no effect. All the extra units are moved into the Sinai or western Egyptian desert where they can remain un-supplied and waste away. I transfer 1 Iraq partisan or a garrison to hold Suez to prevent that placement capture.

I did report this bug a while go in the forum and there was an answer and a game file that was provided to correct, but I didn't have much luck with it. The deal with the Allied player has handled the issue for me.

You should try playing it PBEM as that is the intended audience for the ongoing mods from 2.0 through 4.029. It's a fun game played that way and I have a group that keeps games going all the time.

If you want to give it a try pick a side, probably Axis, and mail me your opening move and "away we'll go"!

Re: Commander EAW Grand Strategy V4 Issues

Posted: Sat Sep 14, 2019 2:14 am
by GeneralButtercup82
Here is another way to handle this glitch

Re: How do you stop this?
Report this post Quote
Unread post by fangotango ยป 05 Aug 2019 02:57

The only way I found to prevent this situation is to NOT occupy Kuwait city as the Axis. You might want to agree with your opponent that Kuwait remain "neutral", or establish some criteria that would allow the Allies to eventually occupy Kuwait city.

Re: Commander EAW Grand Strategy V4 Issues

Posted: Wed Sep 18, 2019 9:21 pm
by VeganTed
Many thanks for your prompt response, General Buttercup, and for your suggestions.

Unfortunately, PBEM is not a viable option for me - I tend to play the game during the night and for several hours at a time. What puzzles me is why there aren't hundreds of complaints of the same nature from other players; do they not experience this issue (in V4)?

I am equally puzzled as to why no-one else appears to have experienced the same anomalies as I reported above regarding V3. Am I not looking in the correct place in the forum? Do you have any ideas about V3 bugs or know of someone who does? Do I really have to just wait and hope that some kind soul (such as your good self) will notice my posting, know the solution, and reply to me? Seems to me like a bit of a hit-and-miss way of providing support for a product. Or is it simply that the game is so old that few people play it any longer and/or it is unsupported? Or have I posted in the wrong place?

Thanks again,

Andy Terry

Re: Commander EAW Grand Strategy V4 Issues

Posted: Tue Sep 24, 2019 11:27 am
by Peter Stauffenberg
Try out this file for the spawn issue in Egypt. It's important that BOTH players install the fix or your opponent will cause the spawning from happening since he has the old file.

I would also go back to the time prior to the fall of Egypt (Cairo and Kuwait Axis controlled) to prevent any spawns from happening. The reason is that if you have already had the spawn you have falsely activated Egypt in the game again.

The cause of the issue was that a code line checking if Egypt was conquered was missing when checking for Iraq activation. The code checked if there were German units in Libya and Egypt was not active. Then Egypt would activate. Activation of Egypt would also activate Iraq. This code was added to ensure the Allies got some of their reinforcements if the Axis players decided to enter Libya with German units earlier than the historical date. The Allies would have responded to the Germans sending units to Libya by sending forces to Egypt and Iraq from the Far East. Earlier the Axis player could exploit this by attacking early and roll over Egypt.

We removed quite a few of the Allied player units in Egypt and Iraq to prevent the Allied player from doing the trick by attacking Italy very early with lots of units meant to be reinforcements from the Far East. So now the reinforcements are arriving when they should be and not at a scripted date.

This file will also fix the issue with Bandar Pahlavi not working as a port. Bandar Pahlavi was linked to a supply depot instead of a rail depot because there was no rail link to the port during WW2. However, supply depots only have supply level 2 and the unload button required supply level 3 to be lit. I created an exception for supply depots.

This file will also prevent deploying land units on airfields (Gibraltar and Malta)

Please try out this file: ... class?dl=0

Game.class should be placed in the game folder under your game installation folder. Remember to backup the old game.class first.

Re: Commander EAW Grand Strategy V4 Issues

Posted: Tue Sep 24, 2019 11:34 am
by Peter Stauffenberg
Grand Strategy is not made for play vs the AI. Therefore the game behavior can be strange when the opponent is the AI since the AI code is based upon the original CEAW version. E. g. the AI won't take advantage of amphibious landings, conversion of units to SS or paratrooper and so on.

You can also get into crash or anomaly situations because the AI does things the game code won't allow in GS, but was allowed in CEAW. One example is hidden subs on sentry mode. Now naval units will sail through the hidden subs and dislodge the sub if it lands in the same hex as the sub. In CEAW subs always made a surprise attack if you sailed over it. Now you can make the sub passive by putting it on sentry mode. Then the sub works as a spy unit. You have to actively search for the sub to find it (also new in CEAW).

So I recommend you don't play against the AI. First the AI is very poor strategy wise so you can easily beat it. I usually manage to hold France throughout the game because the Axis AI can't attack efficiently into Belgium and France.

Second is that you never know if you can even finish the game due to anomalies etc. So you're setting yourself up for frustrations attempting an AI game. Same with TCP/IP games. GS is not optimized for TCP/IP games either. PBEM was the only scope for GS.