Page 1 of 1

different versions in the same forum

Posted: Sun Feb 02, 2014 4:05 am
by JimWC
I just ran into an annoying problem. I responded to an open challenge and discovered after a few turns that my opponent is on the 1.4 beta. I'm not, but there was no way to determine that when I responded to the challenge. The game is now crashing -- not a surprise since we're on different program versions. There should have been some identification of the program version at the beginning. This is particularly annoying since I don't have any way of communicating with my opponent outside of the game chat, and can't apologize for abandoning the game. It strikes me that this is a weakness of the CGW PBEM system -- a bit not fully thought through. Although I generally like the server based system, in CEAW at least you have a player's email address to communicate outside of the game.

This may not be an issue for those players who like to remain anonymous, but it seems to me that the level of politeness declines as the level of anonymity increases.

Re: different versions in the same forum

Posted: Sun Feb 02, 2014 12:19 pm
by lordzimoa
Hi JimC

The 1.4 version is an Open Beta version, the official 1.4 patch is due very soon, so all should be on the same version after release.

Anyway, our normal policy is that we keep all platforms on the same version on the public servers.

So we put Closed Beta`s on the Beta test server, so they cannot play on the public server, now as this is an Open Beta we made an exception, so more people would test it and like this we got more feedback.

But you are right this the downside using Open Beta`s, again it is a bit of an exception and temporarily.

Re: different versions in the same forum

Posted: Sun Feb 02, 2014 3:32 pm
by JimWC
You should have a way to identify which version of the game the player is using before someone chooses to respond. It seems likely there will be players using the forum who have different released versions of the game as well. Not everybody upgrades at the same time.

Re: different versions in the same forum

Posted: Sun Feb 02, 2014 4:52 pm
by lordzimoa
When the official patch is out, everybody starting up the game gets a warming a new update is out and on top when logging into the server using MP, you will get this warning again and only those who upgrade can get in and play, so this will never be an issue after the official patch.

This is a standard procedure we implement for every official update,

Again exception, being using open Beta.... , you can see what version you have in the credits menu, this on a side note.

But a good point we can make this more clear next time we opt using an Open Beta test, so we put it on the wishlist. ;-)

Re: different versions in the same forum

Posted: Sun Feb 02, 2014 5:36 pm
by JimWC
What about players who have ongoing games under an old version?

Re: different versions in the same forum

Posted: Sun Feb 02, 2014 7:34 pm
by lordzimoa
They can continue, just not accept or start new games, until they are upgraded.

Re: different versions in the same forum

Posted: Wed Feb 26, 2014 2:14 am
by JimWC
lordzimoa wrote:They can continue, just not accept or start new games, until they are upgraded.
This does not appear to be true any longer. I have not upgraded to 1.4, nor has my opponent. I now get an error message that my client is out of date and I need to upgrade it.

Re: different versions in the same forum

Posted: Wed Feb 26, 2014 7:17 am
by lordzimoa
Yes, this is not a Beta patch anymore, but the official patch 1.4.2. So also using the public servers, to be able to play MP, everybody needs to be on the same version, so if you both upgrade, you will be fine.