Firing animation lag

Forum for the strategy game set during the 2nd War for Armageddon.

Moderators: Slitherine Core, BA Moderators, WH40K Armageddon moderators, Slitherine Core, BA Moderators, WH40K Armageddon moderators

Post Reply
Malcador
Lance Corporal - Panzer IA
Lance Corporal - Panzer IA
Posts: 15
Joined: Thu Nov 27, 2014 1:17 pm

Firing animation lag

Post by Malcador » Thu Nov 27, 2014 1:21 pm

Hi guys!

First of all, congratulations for such awesome game, it really brought the feel of WH4k as no other game!

However, I noticed this annoying issue:

Firing animations are laggy, but only when they appear for the fist time.

Example:
A Lasgun fires for the first time: laggy as hell-----> lasgun fires again: smooth as butter for the rest of the game UNTIL I exit the game.
No game-breaking issue, but it surely is annoying.

My spec are pretty beefy for such low demanding game, intel core I7, GTX 660, 8 gb of RAM, Windows 8 64bit.


Any ideas on how to solve this?

Rudankort
FlashBack Games
FlashBack Games
Posts: 3615
Joined: Sat Aug 21, 2010 2:23 pm
Contact:

Re: Firing animation lag

Post by Rudankort » Thu Nov 27, 2014 5:39 pm

Thanks for feedback. It's very important for us to know what things annoy the players. Alas, with the current build the only solution is to install the game on an SSD or RAM disk. But we'll look into improving this in the next updates.

Malcador
Lance Corporal - Panzer IA
Lance Corporal - Panzer IA
Posts: 15
Joined: Thu Nov 27, 2014 1:17 pm

Re: Firing animation lag

Post by Malcador » Thu Nov 27, 2014 7:09 pm

Rudankort wrote:Thanks for feedback. It's very important for us to know what things annoy the players. Alas, with the current build the only solution is to install the game on an SSD or RAM disk. But we'll look into improving this in the next updates.
Glad to be of help, this is the first game I get from you guys and I am really pleased, can't wait to see further releases.
So, this is an universal issue and not just related to my machine? I suppose that 90% of the guys here got old style hard disks?

I am no tech savy, but I found that a simple workaround can ease the issue: before playing the campaign you can load up one of the scenarios, the one where you get swarmed by orks in the first turn. Apparently, almost all weapon types get fired and further games are almost lag free.
However, this is rather annoying. Hope you guys find a solution.


I think that the the appeal of this kind of games to modern gamers is the simplicity: no crazy system requirements, no lags, no huge loading times, no driver issues...just click the icon and smash orks!
The workaround up there plus the necessity of using a 3rd party software to limit fps (to avoid my GPU running to melting speed) are really detrimental.

Plus, consider that flashy effects are one of the best graphical things in this game, it's what makes it alive! :P

Rudankort
FlashBack Games
FlashBack Games
Posts: 3615
Joined: Sat Aug 21, 2010 2:23 pm
Contact:

Re: Firing animation lag

Post by Rudankort » Thu Nov 27, 2014 7:14 pm

You are quite right. FPS limit is high on our list too.

Malcador
Lance Corporal - Panzer IA
Lance Corporal - Panzer IA
Posts: 15
Joined: Thu Nov 27, 2014 1:17 pm

Re: Firing animation lag

Post by Malcador » Sun Nov 30, 2014 11:16 am

I am curious, am I the only one experiencing this annoying lag on firing effects?

greywolf101st
Private First Class - Wehrmacht Inf
Private First Class - Wehrmacht Inf
Posts: 7
Joined: Thu Feb 14, 2013 8:20 pm

Re: Firing animation lag

Post by greywolf101st » Sun Nov 30, 2014 11:50 am

No, I get it too and I would love to know why.

Malcador
Lance Corporal - Panzer IA
Lance Corporal - Panzer IA
Posts: 15
Joined: Thu Nov 27, 2014 1:17 pm

Re: Firing animation lag

Post by Malcador » Tue Dec 02, 2014 6:22 pm

Anyone else experiencing this?

Dayta
Corporal - 5 cm Pak 38
Corporal - 5 cm Pak 38
Posts: 41
Joined: Tue Dec 02, 2014 2:26 am

Re: Firing animation lag

Post by Dayta » Tue Dec 02, 2014 7:17 pm

It seems the firing animations aren't preloaded, so when you fire the weapon for the first time they have to load first for each one, and the game pauses while it does that, hence the lag.

Micha63
1st Lieutenant - Grenadier
1st Lieutenant - Grenadier
Posts: 774
Joined: Mon Jul 11, 2011 8:56 pm
Location: Germany
Contact:

Re: Firing animation lag

Post by Micha63 » Tue Dec 02, 2014 9:25 pm

Malcador wrote:Anyone else experiencing this?
For me is the same.

Aekar
Sergeant - 7.5 cm FK 16 nA
Sergeant - 7.5 cm FK 16 nA
Posts: 231
Joined: Thu Nov 27, 2014 10:29 am

Re: Firing animation lag

Post by Aekar » Wed Dec 03, 2014 10:46 am

I had it once, and only on a specific map. Never had it so far on other maps (but 1.01 version it still recent).

It then happened with ever firing animation until I reloaded the game.
And then it was fixed, but could begin again at any moment on this map.

The lag I had was :
I click, then the game look like "stuck", and then animation resumes after a few seconds. It then almost immediately gets stuck again.
After a while it works again, but will happen with every animation until I reload the game.


It doesn't look like a general performance issue, but something different, like a stuck "code loop".
Was yesterday, december 2nd, so this was with the latest version (1.01).

The map was :
Defending Tartarus Industry, on Act 2



Can you share details about your own experience?
I want to know if it is different from mine!

JimmyC
Sergeant Major - Armoured Train
Sergeant Major - Armoured Train
Posts: 596
Joined: Tue Jan 14, 2014 10:31 am

Re: Firing animation lag

Post by JimmyC » Wed Dec 03, 2014 11:41 am

I never had this problem so far. Although maybe i just didn't notice it? I will fire up the game later and check.

Caveman
Corporal - Strongpoint
Corporal - Strongpoint
Posts: 59
Joined: Sat Jul 16, 2011 1:34 pm

Re: Firing animation lag

Post by Caveman » Wed Dec 03, 2014 12:31 pm

Have this too - I think I could even spot it in the twitch-gaming-video from Ian McNeal himself. Some pre-loading would be cool.

Post Reply

Return to “Warhammer® 40,000® Armageddon™”