PSP MITHRAS game crash/hang

Post your Technical Support questions here. Requires forum registration.

Moderator: Slitherine Core

Post Reply
prizes247
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 2
Joined: Wed Jul 16, 2008 1:03 am

PSP MITHRAS game crash/hang

Post by prizes247 » Wed Jul 16, 2008 1:27 am

Please help. Have completed all Rome battles and all Celtic battles. but whenever I try to play 2nd ascension to Saturn the game hangs/freezes and then the psp turns off. Game is English version bought in game in Leicester

pipfromslitherine
Site Admin
Site Admin
Posts: 8951
Joined: Wed Mar 23, 2005 10:35 pm

Post by pipfromslitherine » Wed Jul 16, 2008 4:12 pm

The only thing I can think of is that perhaps there is a scratch or dirt on the disk? Try cleaning it and see if that helps, or if it is damaged then try and get a replacement disk.

Cheers

Pip

prizes247
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 2
Joined: Wed Jul 16, 2008 1:03 am

Post by prizes247 » Thu Jul 17, 2008 6:42 pm

:cry: not a single mark on the disk it is mint. crash happens as soon as both sides meet.
Please help. I have loved playing this game and have spent ages making the best army I can to take this far

pipfromslitherine
Site Admin
Site Admin
Posts: 8951
Joined: Wed Mar 23, 2005 10:35 pm

Post by pipfromslitherine » Thu Jul 17, 2008 6:56 pm

It's not an issue we have seen before. Can you try using a different army, perhaps disbanding units one by one and seeing if it changes anything.

Cheers

Pip

james1
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 1
Joined: Sun Oct 05, 2008 11:31 am

PSP Mithras crash

Post by james1 » Sun Oct 05, 2008 11:46 am

Hi there. I have had the same problem on the PSP - but I have had it happen firstly when I reach the 'million miles of sea', and then on the next battle - the final one with Avisius (I think) which I have yet to fight - it locks up within 10-20 seconds of starting. I think it crashed as I might have had too many units on 'long wait' - with some finessing I managed to complete the previous battle, with very few on 'wait' and also having to issue the signal to move before a certain time (otherwise it again hangs), but it plays havoc with the positioning of my army, as I have to stop each one moving and get them back in position before they start fighting anyone. Please post if anyone has any luck with this as it is extremely frustrating, and the psp is the perfect shape to hurl violently against a wall after the wait to load and then arrange the units is followed by it crashing before you even join battle!

IainMcNeil
Site Admin
Site Admin
Posts: 13498
Joined: Fri Apr 01, 2005 10:19 am

Post by IainMcNeil » Tue Oct 07, 2008 3:34 pm

Sorry you're having problems. You could try reducing the size of your army, maybe using less squads as it is more likely there is a memory overload than the ordes causing issues. Obviously if we had caught the bug in testing we'd have fixed it but this seems to have slipped through, possibly because it is so far in to the game. There is not much we can do to help at this stage unfortunately :(

Post Reply

Return to “THE HISTORY CHANNEL Great Battles of Rome : Tech Support”