Cannot play Sovereignty

Moderators: Slitherine Core, Gothic Labs

Post Reply
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 2
Joined: Fri Apr 04, 2014 11:05 am

Cannot play Sovereignty

Post by karasbomber » Mon Apr 03, 2017 3:42 pm

After several weeks of playing the game,and enjoying it immensely,by having great success as Jotland,and becoming a great power,I am now unable to play the game at all.It all seemed to start after playing a couple of hours one morning,I saved the game as I usually do.Then I decided to run a defrag of my C drive, because I am shortly going to install an SSD drive.The drive itself was not to bad,and defrag only took about 20 mins or so.
Later in the evening I attempted to play the game again,clicking on my desktop startup menu,the initial screen appeared as usual,and I clicked play.Now heres where it all goes silly,the appearance of an outline of a rectangular box appears,for a fleeting second,similar in size to the startup screen,the intro music then plays as it used to before,but Im not getting the screen that allows me to select saved game new game etc.
I am quite frustrated,as I have even deleted the game from the C drive,and reinstalled from the disc as if a fresh installation and it still will not work.Even tried installing it from steam and it still will not play.
After several attempts,I downloaded the patch from the startup screen to the latest version of the game and still I get the same result.
The hard copy disc serial number is , and underneath is the number ,and the game was purchased on 27/02/2017.
Any thoughts would be appreciated.
PS. I am not a computer whizz kid or anything like that,I cant even cut and paste,so if you have any ideas I hope their not complicated.

edited by zakblood, all serial numbers have been removed

Most Active User 2017
Most Active User 2017
Posts: 15954
Joined: Thu Jun 12, 2014 6:44 pm

Re: Cannot play Sovereignty

Post by zakblood » Mon Apr 03, 2017 7:11 pm

sorry for your issues,

Could you please attach a DxDiag report file to your message / reply?

Please attach a DxDiag report fie.
How to get a DxDiag report file:

1. Click on "START" (on Windows 8/10 press “Windows key” and the “R” key at the same time)
2. Click "run" (skip this step on Windows 8/10)
3. Type in "dxdiag" and click "OK"
4. Check through the tabs and perform all tests
5. Click "Save all Information..." and save the text file to a location of your choice
6. Attach the file to your message
7, if your new and can't / don't have permission etc, then copy paste into a reply

Most Active User 2017
Most Active User 2017
Posts: 15954
Joined: Thu Jun 12, 2014 6:44 pm

Re: Cannot play Sovereignty

Post by zakblood » Mon Apr 03, 2017 7:22 pm

as you have said, the game worked before you defragged your hard drive, we both know the games works on your hardware,

so something has altered that fact,


missing files.
a updated file on the pc.
a update to your operating system, replaced and or updated file etc.

how to recover from it, now you have uninstalled it.

steam or stand alone, makes little difference, as each way is the same, as long as your un installed it by the correct method.

i will take it as you have used the uninstall wizard in the game and take it from there.

go into where you last installed the game, either in the steam folder or the C drive, as you have done both, look at both folders.

search for Sovereignty, on your pc, it will be in 3 places, if any folders are left, delete them, and also the folder in your documents folder.

then search for it again, once it says there isn't any, you can re install.

default install, depending on Operating system, always install as admin, as this sets up all the permissions for you, and update it online, standalone and steam version etc, steam is easier as it does it for you, site version is a manual one, eg click on the update button.

make sure when it asks if it does ask you to install all prerequisites say yes, if it doesn't ask you, go into the game install folder and run them manually _CommonRedist and run all 4 files in 4 folders
It will have the original version. So you'll need to update it from the Internet.
Please note that you'll only need the last update, as our updates are comprehensive.

add the exe of the game to your Anti Virus and firewall program, to make sure to check the logs of these to see if it was one of them which was to blame.

run the game from a admin account and use full admin permissions.

please make sure all game pre requisite are installed with the game, even if you think or fully know there are already installed, it will only over write, and it may be that you have a older or newer version of these where as the game in question may need a certain version.

Post Reply

Return to “Sovereignty: Tech Support”