Save bug

Moderators: Order of Battle Moderators, The Artistocrats

Post Reply
ammobelt
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 2
Joined: Sun May 19, 2013 8:50 am

Save bug

Post by ammobelt » Sun May 03, 2015 7:56 am

After round 22 on Guadalcanal senario as Japan the turn overview stops poping up after the AI finish its turn.
Naval units also are shown as already moved and fired and you can nolonger press end turn or save the game.
This I could fix by disabling autosave. I can now continue playing but it still wont let me save which makes things difficult in the long run.
If I load the game 1 turn earlier I can save as normal.

ammobelt
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 2
Joined: Sun May 19, 2013 8:50 am

Re: Save bug

Post by ammobelt » Sun May 03, 2015 10:40 am

Here is the log file
Attachments
output_log.zip
(1.98 KiB) Downloaded 58 times

stragen
Lance Corporal - SdKfz 222
Lance Corporal - SdKfz 222
Posts: 24
Joined: Fri May 08, 2015 12:45 pm

Re: Save bug

Post by stragen » Thu May 14, 2015 1:55 pm

Did you get fixed that problem?

Myrddraal
The Artistocrats
The Artistocrats
Posts: 1505
Joined: Wed Feb 23, 2011 2:49 pm

Re: Save bug

Post by Myrddraal » Thu May 14, 2015 3:11 pm

It looks like the game is having issues generating the savegames. It may be a windows permissions error? I suggest try running the game with administrator privileges if you can, and see if this clears the error.

stragen
Lance Corporal - SdKfz 222
Lance Corporal - SdKfz 222
Posts: 24
Joined: Fri May 08, 2015 12:45 pm

Re: Save bug

Post by stragen » Thu May 14, 2015 5:07 pm

To test that i started a new US campaign. And there is no problem with saving. The bug appeared as Japan in Guadalcanal like OP.

fsx
Warhammer Moderator
Warhammer Moderator
Posts: 388
Joined: Mon Dec 26, 2011 2:47 pm

Re: Save bug

Post by fsx » Thu May 14, 2015 8:48 pm

Myrddraal wrote:It looks like the game is having issues generating the savegames. It may be a windows permissions error? I suggest try running the game with administrator privileges if you can, and see if this clears the error.
Its not a access issue. I started the Order of Battle - Pacific.exe (not the autorun) as admin. Same probleme as described at viewtopic.php?f=372&t=64618
The new turn window dont appears at the end of the AI turn.

Error message in the output_log:

Failed to get pixels of splat texture

and

Code: Select all

NullReferenceException: Object reference not set to an instance of an object
  at FilesAI.WriteAITeams (System.IO.BinaryWriter writer) [0x00000] in <filename unknown>:0 

  at FilesAI.CreateStream () [0x00000] in <filename unknown>:0 

  at Files.GetSectionData (sections section) [0x00000] in <filename unknown>:0 

  at Files.SaveScenario (.sections[] includedSections) [0x00000] in <filename unknown>:0 

  at Files.SaveToDisk (System.String fileName, System.String pathName, types type) [0x00000] in <filename unknown>:0 

  at GameUI.OnPhaseStart (.Alliance alliance) [0x00000] in <filename unknown>:0 

  at ScenarioLauncher.StartPhase (.GameState gameState) [0x00000] in <filename unknown>:0 

  at ScenarioLauncher.EndPhase (.GameState gameState) [0x00000] in <filename unknown>:0 

  at ActionsNamespace.EndPhaseAction.Perform (.GameState gameState, Boolean checkVisibility, .Alliance visibilityAlliance) [0x00000] in <filename unknown>:0 

  at ActionsNamespace.Action.PerformWithVisibilityCheck (.Alliance alliance) [0x00000] in <filename unknown>:0 

  at ActionManager.PlaybackNext () [0x00000] in <filename unknown>:0 

  at ActionManager.Update () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)

HandleD3DDeviceLost
  HandleD3DDeviceLost: needs reset, doing it
FullResetD3DDevice
ResetD3DDevice
dev->Reset
D3Dwindow device not lost anymore
NullReferenceException: Object reference not set to an instance of an object
  at FilesAI.WriteAITeams (System.IO.BinaryWriter writer) [0x00000] in <filename unknown>:0 

  at FilesAI.CreateStream () [0x00000] in <filename unknown>:0 

  at Files.GetSectionData (sections section) [0x00000] in <filename unknown>:0 

  at Files.SaveScenario (.sections[] includedSections) [0x00000] in <filename unknown>:0 

  at Files.SaveToDisk (System.String fileName, System.String pathName, types type) [0x00000] in <filename unknown>:0 

  at FilesPanel.Save () [0x00000] in <filename unknown>:0 

  at FilesPanel.OnGUI () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)


adherbal
The Artistocrats
The Artistocrats
Posts: 3892
Joined: Fri Jun 24, 2005 6:42 pm
Location: Belgium

Re: Save bug

Post by adherbal » Thu May 14, 2015 11:51 pm

We've identified and fixed the issue. If it's too late for tomorrow's patch we'll provide a quick hotfix for you. Stay tuned.
Image

stragen
Lance Corporal - SdKfz 222
Lance Corporal - SdKfz 222
Posts: 24
Joined: Fri May 08, 2015 12:45 pm

Re: Save bug

Post by stragen » Fri May 15, 2015 9:42 am

Can you describe the problem? Maybe we can work around it then.

Myrddraal
The Artistocrats
The Artistocrats
Posts: 1505
Joined: Wed Feb 23, 2011 2:49 pm

Re: Save bug

Post by Myrddraal » Fri May 15, 2015 9:53 am

It has made it into the patch. Unfortunately I don't think it's not something you work-around yourselves, but the patch has gone out the door now and should be with you very shortly.

Post Reply

Return to “Order of Battle : World War II - Tech Support”