TT Mod version 1.5.3 (NOW REPLACED BY v1.5.18 - see separate thread)

Field of Glory II is a turn-based tactical game set during the Rise of Rome from 280 BC to 25 BC.
dkalenda
Sergeant - Panzer IIC
Sergeant - Panzer IIC
Posts: 176
Joined: Wed Dec 19, 2012 4:49 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by dkalenda » Tue Jan 15, 2019 10:16 pm

Sorry for bothering you, but I really can't run the TT Mod!

Everytime I try to play on multiplayer the game is stuck with a Script Error message (as attached).

Any suggestion?
Attachments
FOG II nap. screen.jpg
FOG II nap. screen.jpg (275.7 KiB) Viewed 1737 times

Paul59
Brigadier-General - 8.8 cm Pak 43/41
Brigadier-General - 8.8 cm Pak 43/41
Posts: 1814
Joined: Tue Jul 21, 2015 11:26 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by Paul59 » Wed Jan 16, 2019 12:27 am

dkalenda wrote:
Tue Jan 15, 2019 10:16 pm
Sorry for bothering you, but I really can't run the TT Mod!

Everytime I try to play on multiplayer the game is stuck with a Script Error message (as attached).

Any suggestion?
That error message is referring to the Napoleonic mod! I don't think that mod works anymore, because it's scripts are incompatible with the new 1.5.3 version of FOG2. It must be interfering with your ability to play other mods, including the TT Mod. I would suggest deleting the Napoleonic Mod from your system and see if that solves the problem.

PS: What exactly were you doing before that Error Message popped up? I mean, what had you just clicked that caused that message to appear, and were you creating or accepting a challenge? Was this a Paired Match?
Scenario Designer - Age of Belisarius, Rise of Persia, and Wolves at the Gate.

TT Mod Creator

dkalenda
Sergeant - Panzer IIC
Sergeant - Panzer IIC
Posts: 176
Joined: Wed Dec 19, 2012 4:49 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by dkalenda » Thu Jan 17, 2019 11:32 pm

Antoher episode:

the problem is that I don't have any Napoleonic mod installed, no files related to Napoleon is in my computer. But now I've another pop up:

P.S. Before the Error Message I just clicked to play an accepted challenge, which was a Paired Match.

Thanks Paul anyway...
Attachments
screen.PNG
screen.PNG (301.26 KiB) Viewed 1690 times

Paul59
Brigadier-General - 8.8 cm Pak 43/41
Brigadier-General - 8.8 cm Pak 43/41
Posts: 1814
Joined: Tue Jul 21, 2015 11:26 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by Paul59 » Fri Jan 18, 2019 8:49 am

dkalenda wrote:
Thu Jan 17, 2019 11:32 pm
Antoher episode:

the problem is that I don't have any Napoleonic mod installed, no files related to Napoleon is in my computer. But now I've another pop up:

P.S. Before the Error Message I just clicked to play an accepted challenge, which was a Paired Match.

Thanks Paul anyway...
There seems to be a bug with the Paired Match option at the moment, which the developer is trying to fix. Were you attempting to play a Paired Match before both error messages? Have you tried accepting a non Paired Match TT Mod challenge?
Scenario Designer - Age of Belisarius, Rise of Persia, and Wolves at the Gate.

TT Mod Creator

rbodleyscott
Field of Glory 2
Field of Glory 2
Posts: 22151
Joined: Sun Dec 04, 2005 6:25 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by rbodleyscott » Fri Jan 18, 2019 9:06 am

The second error suggests that you are trying to run the old version of TT Mod, which is not compatible with v1.5.3 of the game.

You need to update to v1.5.3 of TT Mod.

Existing games using the previous version won't work and will have to be abandoned.
Richard Bodley Scott

Image

dkalenda
Sergeant - Panzer IIC
Sergeant - Panzer IIC
Posts: 176
Joined: Wed Dec 19, 2012 4:49 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by dkalenda » Sat Jan 19, 2019 1:50 am

I took a final decision to reinstall the game. Now the TT Mod... Works!!!
Ironically I'm playing with Ulysisgrunt...
Anyway the previous accepted game doesn't work at all, the message now is a simple: "Cannot find a custom scenario....", in this case I think there's something connected with the paired games bug.
If you can delete this game with xabelmagno from the server also the memory of this mess will be finally cancelled :-)

For Ulysisgrunt: "I can create skirmish game challenges, but cannot accept any....Could the problem be that I lack the module that says SKIRMISH ?"

Maybe it's because you tried to accept games using an older TT Mod version...

rbodleyscott
Field of Glory 2
Field of Glory 2
Posts: 22151
Joined: Sun Dec 04, 2005 6:25 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by rbodleyscott » Sat Jan 19, 2019 8:53 am

dkalenda wrote:
Sat Jan 19, 2019 1:50 am
I took a final decision to reinstall the game. Now the TT Mod... Works!!!
Ironically I'm playing with Ulysisgrunt...
Anyway the previous accepted game doesn't work at all, the message now is a simple: "Cannot find a custom scenario....", in this case I think there's something connected with the paired games bug.
No, it is because the TT Mod folder it is looking for is no longer on your system.
If you can delete this game with xabelmagno from the server also the memory of this mess will be finally cancelled :-)
You can delete it yourself once there has been no activity in the game for 7 days.
Richard Bodley Scott

Image

XLegione
Administrative Corporal - SdKfz 232 8Rad
Administrative Corporal - SdKfz 232 8Rad
Posts: 161
Joined: Tue Nov 28, 2017 7:54 pm
Location: Italy

Re: Can't get it to run!

Post by XLegione » Sat Jan 26, 2019 2:10 pm

Ulysisgrunt wrote:
Sun Jan 13, 2019 5:02 am
I've downloaded the three files, extracted them, and placed them in the Campaign directory of the main program. I can create skirmish game challenges, but cannot accept any.
Advice?
Hi Paul59
I have the same problem! I purchased FOG II through Steam and the game directory follows another path than you indicated, I'm able to play single player battle and campaign, create skirmish but cannot accept any and nobody is able to join my game.

May you help me?

Thanks

Ciao

Below you see where I placed the modules:
Attachments
Campaign and custom V1.5.3.PNG
Campaign and custom V1.5.3.PNG (65.25 KiB) Viewed 1524 times
MPV1.5.3.PNG
MPV1.5.3.PNG (18.55 KiB) Viewed 1524 times

rbodleyscott
Field of Glory 2
Field of Glory 2
Posts: 22151
Joined: Sun Dec 04, 2005 6:25 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by rbodleyscott » Sat Jan 26, 2019 5:49 pm

That is the wrong place. The place that Mods should go is the same whether using STEAM or non-STEAM versions. They should not go in the game build. Although the game will find the SP folders even if you do put them in the game build, it won't find MP folders in the game build.

As per the original post at the top of the thread, the MP version should go in

/Documents/My Games/FieldofGlory2/MULTIPLAYER

or it may be

/My Documents/My Games/FieldOfGlory2/MULTIPLAYER

(It varies depending on the version of Windows you are using)

The folder will certainly already exist, if you have ever run the game, you don't have to create it. If you cannot find it, you are looking in the wrong place.

Although they will work in the main build, SP Mods are supposed to go in:

/Documents/My Games/FieldofGlory2/CAMPAIGNS

or it may be

/My Documents/My Games/FieldOfGlory2/CAMPAIGNS
Richard Bodley Scott

Image

XLegione
Administrative Corporal - SdKfz 232 8Rad
Administrative Corporal - SdKfz 232 8Rad
Posts: 161
Joined: Tue Nov 28, 2017 7:54 pm
Location: Italy

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by XLegione » Sat Jan 26, 2019 6:18 pm

Many thanks!
Fixed and it works now!


Ciao

XLegione

Paul59
Brigadier-General - 8.8 cm Pak 43/41
Brigadier-General - 8.8 cm Pak 43/41
Posts: 1814
Joined: Tue Jul 21, 2015 11:26 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by Paul59 » Sat Jan 26, 2019 10:05 pm

XLegione wrote:
Sat Jan 26, 2019 6:18 pm
Many thanks!
Fixed and it works now!


Ciao

XLegione
Many thanks for giving those screenshots of where you installed the mods. It makes solving your problem very easy for us!

I am glad it all works!


Ciao


Paul
Scenario Designer - Age of Belisarius, Rise of Persia, and Wolves at the Gate.

TT Mod Creator

SteveD64
Senior Corporal - Destroyer
Senior Corporal - Destroyer
Posts: 121
Joined: Mon Oct 20, 2014 2:46 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by SteveD64 » Sun Jan 27, 2019 12:06 am

Does the Greek (Asiatic) army list refer to the Greek colonies of Asia Minor?

Paul59
Brigadier-General - 8.8 cm Pak 43/41
Brigadier-General - 8.8 cm Pak 43/41
Posts: 1814
Joined: Tue Jul 21, 2015 11:26 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by Paul59 » Sun Jan 27, 2019 10:22 am

SteveD64 wrote:
Sun Jan 27, 2019 12:06 am
Does the Greek (Asiatic) army list refer to the Greek colonies of Asia Minor?
That is correct.
Scenario Designer - Age of Belisarius, Rise of Persia, and Wolves at the Gate.

TT Mod Creator

SteveD64
Senior Corporal - Destroyer
Senior Corporal - Destroyer
Posts: 121
Joined: Mon Oct 20, 2014 2:46 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by SteveD64 » Tue Jan 29, 2019 1:24 pm

Thanks! Are the Ptolemies missing an Army List? Their list stops sooner than the vanilla version.

Paul59
Brigadier-General - 8.8 cm Pak 43/41
Brigadier-General - 8.8 cm Pak 43/41
Posts: 1814
Joined: Tue Jul 21, 2015 11:26 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by Paul59 » Tue Jan 29, 2019 1:44 pm

SteveD64 wrote:
Tue Jan 29, 2019 1:24 pm
Thanks! Are the Ptolemies missing an Army List? Their list stops sooner than the vanilla version.
No, they should both cover the same period, 320 - 30 BC. Here is a screenshot of the vanilla Ptolemaic armies:

Image

Here are the ones from TT Mod 1.5.3:

Image

I don't know what you are looking at?


cheers


Paul
Scenario Designer - Age of Belisarius, Rise of Persia, and Wolves at the Gate.

TT Mod Creator

SteveD64
Senior Corporal - Destroyer
Senior Corporal - Destroyer
Posts: 121
Joined: Mon Oct 20, 2014 2:46 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by SteveD64 » Tue Jan 29, 2019 6:07 pm

Ah! never mind! The rest were filtered out because of the date of the army list I was using.

lydianed
Staff Sergeant - Kavallerie
Staff Sergeant - Kavallerie
Posts: 345
Joined: Sat Sep 10, 2011 12:35 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by lydianed » Sat Feb 09, 2019 12:02 am

Guys,

Have followed Paul's instructions and downloaded the 1.5.3MPV mod and installed it in the correct place on my computer. However, I cannot accept a challenge from a player using this mod. I read that Paul says to click on "Select another module" but where is this dialogue box? I go into the main screen, click multiplayer from the menu and it takes me in. I have no option to select another module. M'aidez.

stockwellpete
Field of Glory Moderator
Field of Glory Moderator
Posts: 9232
Joined: Fri Oct 01, 2010 2:50 pm
Contact:

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by stockwellpete » Sat Feb 09, 2019 12:07 am

lydianed wrote:
Sat Feb 09, 2019 12:02 am
Guys,

Have followed Paul's instructions and downloaded the 1.5.3MPV mod and installed it in the correct place on my computer. However, I cannot accept a challenge from a player using this mod. I read that Paul says to click on "Select another module" but where is this dialogue box? I go into the main screen, click multiplayer from the menu and it takes me in. I have no option to select another module. M'aidez.
From the FOG2DL thread . . .

Re: Any questions?
Post by stockwellpete » 06 Feb 2019 23:52

The full sequence for using the TTmod is as follows . . .

Go in to Multi-player
Log In
My Challenges
New Challenge
Create Skirmish
Select Another Module in the Custom Battle Screen (it is the little square box to the right of the brown Field of Glory 2 banner)
Click on TTmod MP v1.5.3
Launch
Select Armies and keep default game options
Create
Enter password and any Comments
Create

rbodleyscott
Field of Glory 2
Field of Glory 2
Posts: 22151
Joined: Sun Dec 04, 2005 6:25 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by rbodleyscott » Sat Feb 09, 2019 8:07 am

That is to create a challenge. To accept one you should just be able to accept it from the list of challenges as normal. If you have the mod installed in the right place.
Richard Bodley Scott

Image

Paul59
Brigadier-General - 8.8 cm Pak 43/41
Brigadier-General - 8.8 cm Pak 43/41
Posts: 1814
Joined: Tue Jul 21, 2015 11:26 pm

Re: New TT Mod version 1.5.3 AVAILABLE HERE!

Post by Paul59 » Sat Feb 09, 2019 2:25 pm

There have been a few similar issues posted before, they all turned out to be caused either by the TT Mod not being installed correctly, or that the player's download was corrupted.

The solution would be to double check the instructions, and make sure that you have installed the mod in the right place. You could post a screenshot in this thread to show us where you have put it. If the Mod is installed in the right place, then it is probably a corrupted download, so delete the mod and download it again.
Scenario Designer - Age of Belisarius, Rise of Persia, and Wolves at the Gate.

TT Mod Creator

Post Reply

Return to “Field of Glory II”