[1.6.3]Can not apply Cybork Implants over lesser version

Tech Support
Post Reply
zgrssd
Private First Class - Wehrmacht Inf
Private First Class - Wehrmacht Inf
Posts: 8
Joined: Wed May 13, 2020 3:02 pm

[1.6.3]Can not apply Cybork Implants over lesser version

Post by zgrssd » Wed Jul 29, 2020 8:05 pm

I think that Cybork Implants level with the Dok that applied them - if the Dok upgrades to a higher version of the Ability all units that had them installed automatically upgrade.

However, what if the Dok in question dies? I had applied Cybork Implants 2 on a Hero. Lost the Dok. New Doks can not overwrite the Buff with their own variant. So the unit is now stuck on the lower variant.

Post Reply

Return to “Warhammer 40,000: Gladius - Relics of War: Tech Support”