Can`t load savegames due to "Incompatible Version 1.0.5"

Tech Support
Post Reply
Ouriso
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 2
Joined: Fri Jul 20, 2018 5:45 am

Can`t load savegames due to "Incompatible Version 1.0.5"

Post by Ouriso » Fri Jul 20, 2018 5:52 am

Almost finished Necron campaign yesterday. Today I realized, that I can`t load any of my savegames due to "Incompatible Version 1.0.5". Strangely this only affects my necron campaign, I am still able to load savesgames from other races. Any fix for that...?

zakblood
Most Active User 2017
Most Active User 2017
Posts: 15315
Joined: Thu Jun 12, 2014 6:44 pm

Re: Can`t load savegames due to "Incompatible Version 1.0.5"

Post by zakblood » Fri Jul 20, 2018 5:58 am

welcome to the forum,

thanks for the report and sorry for your issue, but without a save it would be hard to understand what maybe wrong, a save can be uploaded to a reply, you just need to add it to a zip file

viewtopic.php?f=523&t=86743

above is the link to the developers guide on how to help him help you

DonkeyJockey
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 3
Joined: Fri Jul 20, 2018 7:25 am

Re: Can`t load savegames due to "Incompatible Version 1.0.5"

Post by DonkeyJockey » Fri Jul 20, 2018 7:32 am

This is because they stealth reverted the 1.0.5 patch back to 1.0.4 without thinking of the consequences. Devs, can y'all get on top of this whole maintaining a live civilization style game where savegame compatibility is important? Everything I did in my game yesterday is a waste and I'm just waiting at this point for you guys to update back to 1.0.5 so I don't have to replay everything. That would be greeeeeeeaaaaaaaat. Or maybe just a refund would do.

DonkeyJockey
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 3
Joined: Fri Jul 20, 2018 7:25 am

Re: Can`t load savegames due to "Incompatible Version 1.0.5"

Post by DonkeyJockey » Fri Jul 20, 2018 7:33 am

For clarification, anything saved during the time that 1.0.5 was live is going to be incompatible because 1.0.4 is now live and honestly who does that in a software release environment?

Surtur
Site Admin
Site Admin
Posts: 619
Joined: Thu Oct 16, 2008 8:38 am

Re: Can`t load savegames due to "Incompatible Version 1.0.5"

Post by Surtur » Fri Jul 20, 2018 9:27 am

We are sorry about this guys. We know rolling back is an extreme measure, but we had to do it due to the unforeseen errors in 1.0.5. This is certainly not something we want to make a habit off!

We are expecting to push a fixed 1.0.5 within the next hours.

zakblood
Most Active User 2017
Most Active User 2017
Posts: 15315
Joined: Thu Jun 12, 2014 6:44 pm

Re: Can`t load savegames due to "Incompatible Version 1.0.5"

Post by zakblood » Fri Jul 20, 2018 12:37 pm

a fixed 1.0.5 is now live and loaded on steam

DonkeyJockey
Private First Class - Opel Blitz
Private First Class - Opel Blitz
Posts: 3
Joined: Fri Jul 20, 2018 7:25 am

Re: Can`t load savegames due to "Incompatible Version 1.0.5"

Post by DonkeyJockey » Fri Jul 20, 2018 6:15 pm

This is a top level business problem I'm guessing. If y'all had the proper amount of money invested in game testing, this would never have been an issue. Please send this thread up to the business and marketing folks so they can see just how the image of Slitherine is getting tarnished by their decision not to invest properly in testing their own product that they expect to profit from.

IainMcNeil
Site Admin
Site Admin
Posts: 13496
Joined: Fri Apr 01, 2005 10:19 am

Re: Can`t load savegames due to "Incompatible Version 1.0.5"

Post by IainMcNeil » Mon Jul 23, 2018 2:55 pm

The issue was the team were trying to get fixes out ASAP. We could have sent it to a full test pass but it would have delayed any release a week. This would have generated a completely different set of complaints. We did a quick check but clearly not enough and we apologize for that but I want to be clear this is not about money. Testing is not that expensive, but it is time consuming. Its about balancing getting updates to you as fast as possible without breaking anything. Its a fine line and you're always going to get it right sometimes and wrong others. We get it right most of the time but that doesn't stop it be annoying when we get it wrong :(

Post Reply

Return to “Warhammer 40,000: Gladius - Relics of War: Tech Support”